Make the Switch: Novell's Guide to the Novell® Linux® Desktop
Make the Switch
Novell Linux Desktop

(c) 2004 Novell Inc.
Proprietary Statement

Copyright 2004 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express prior consent of the publisher. This manual, and any portion thereof, may not be copied without the express written permission of Novell, Inc.

Novell, Inc.
1800 South Novell Place
Provo, UT 84606

Disclaimer

Novell, Inc. makes no representations or warranties with respect to the contents or use of this manual, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication and to make changes in its content at any time, without obligation to notify any person or entity of such revisions or changes. Further, Novell, Inc. makes no representations or warranties with respect to any of its software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of its software at any time, without obligation to notify any person or entity of such changes. This Novell Training Manual is published solely to instruct students in the use of Novell networking software. Although third-party application software packages are used in Novell training courses, this is for demonstration purposes only and shall not constitute an endorsement of any of these software applications. Further, Novell, Inc. does not represent itself as having any particular expertise in these application software packages and any use by students of the same shall be done at the students’ own risk.

Software Piracy

Throughout the world, unauthorized duplication of software is subject to both criminal and civil penalties. To report the illegal duplication or distribution of Novell software or Novell training materials, please send an email to purates@novell.com, visit Novell’s anti-piracy web site at www.novell.com/piracy, or phone 1-800-PIRATES (747-2837).
Trademarks

Novell, the Novell logo, NetWare, BorderManager, ConsoleOne, DirXML, GroupWise, iChain, ManageWise, NDPS, NDS, NetMail, Novell Directory Services, Novell iFolder, Novell Secret-Store, Ximian, Ximian Evolution and ZENworks are registered trademarks; CDE, Certified Directory Engineer and CNE are registered service marks; eDirectory, Evolution, exteNd, exteNd Composer, exteNd Directory, exteNd Workbench, Mono, NIMS, NLM, NMAS, Novell Certificate Server, Novell Client, Novell Cluster Services, Novell Distributed Print Services, Novell Internet Messaging System, Novell Storage Services, Nsure, Nsure Resources, Nterprise, Nterprise Branch Office, Red Carpet and Red Carpet Enterprise are trademarks; and Certified Novell Administrator, CNA, Certified Novell Engineer, Certified Novell Instructor, CNI, Master CNE, Master CNI, MCNE, MCNI, Novell Education Academic Partner, NEAP, Ngage, Novell Online Training Provider, NOTP and Novell Technical Services are service marks of Novell, Inc. in the United States and other countries. SUSE is a registered trademark of SUSE LINUX AG, a Novell company. For more information on Novell trademarks, please visit http://www.novell.com/company/legal/trademarks/tmlist.html.

Other Trademarks

All third-party trademarks are the property of their respective owners.
## Contents

### 3 Linux Installation and Components

- 3.1 Novell Linux Desktop Components ........................................ 14
- 3.2 How to Install Novell Linux Desktop .................................. 14
  - 3.2.1 Novell Linux Desktop Installation Methods and Tools ........ 14
  - 3.2.2 The Start Screen .................................................. 15
  - 3.2.3 Base Installation .................................................. 17
  - 3.2.4 Configuration ...................................................... 23

### 4 Explore and Configure the GNOME Desktop

- 4.1 How to Log In and Log Out of the GNOME Desktop ................. 34
  - 4.1.1 Logging In ....................................................... 34
  - 4.1.2 Logging Out ..................................................... 35
- 4.2 How to Shut Down and Reboot the Linux System .................... 37
- 4.3 The GNOME Desktop and Windows ..................................... 38
  - 4.3.1 Desktop .......................................................... 39
  - 4.3.2 Top Panel ........................................................ 39
  - 4.3.3 Bottom Panel ................................................... 40
  - 4.3.4 The Programs Menu .............................................. 41
  - 4.3.5 The Clipboard ................................................... 42
  - 4.3.6 Managing Icons ................................................ 42
  - 4.3.7 Managing Windows .............................................. 43
- 4.4 How to Modify the GNOME Environment ............................... 46
- 4.5 How to Access a Command Line from Within GNOME ................ 49
- 4.6 How to Change Your Password ......................................... 51
## Manage the Linux File System

5.1 Describe the File System Structure
   - File Names in Linux
   - Basic Principles
   - Structure
   - The Most Important Directories

5.2 How to Use the Nautilus File Manager
   - Navigate through the File System
   - Owner and Access Permissions
   - Creating Directories
   - Copying and Moving
   - Renaming Directories and Files
   - Deleting Directories and Files
   - Connecting Files: Links

5.3 How to Search for Files

5.4 How to Access Removable Media
   - Floppy Disks, CDs, and DVDs
   - USB Sticks

5.5 How to Format a Floppy Diskette

## Work with the Installed Office Suite OpenOffice.org

6.1 A Brief History of OpenOffice.org
6.2 Starting the OpenOffice.org Components
6.3 How to Establish Compatibility with Microsoft Office
6.4 How the OpenOffice.org Components Work Together
## Contents

6.5 How to Configure OpenOffice.org ............................................. 82
6.6 How to get Help for OpenOffice.org ........................................... 83
   6.6.1 Help Agent .................................................................. 83
   6.6.2 Online Help .................................................................. 84

7 Optimize Office Communication and Collaboration ................................ 87
   7.1 Handling E-mail with Evolution .............................................. 88
      7.1.1 Configuring Evolution .................................................. 88
      7.1.2 Reading Mail ............................................................. 96
      7.1.3 Composing and Sending New E-mail .............................. 97
      7.1.4 Replying to a Message ................................................ 98
      7.1.5 Attachments ............................................................. 98
   7.2 Managing Contacts ............................................................ 100
   7.3 Managing Appointments ..................................................... 102
   7.4 Managing Tasks .............................................................. 105
   7.5 Instant Messaging with Gaim .............................................. 106
      7.5.1 Configure Gaim ......................................................... 106
      7.5.2 Using Gaim ............................................................. 109

8 Manage Graphics .......................................................................... 113
   8.1 Create a Screenshot to Be Used with OpenOffice Writer .............. 114
      8.1.1 Create a Screenshot ..................................................... 114
   8.2 Create a Drawing with OpenOffice Draw and Use It in OpenOffice Writer .................................................. 116
      8.2.1 Create a Drawing ......................................................... 116
   8.3 Processing Pixel Images with Gimp and Using Them in OpenOffice Writer .............................................. 118
      8.3.1 Basics ................................................................. 118
## Contents

### 11 Advanced Linux File System Techniques

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.1</td>
<td>How to Archive Files with File Roller</td>
<td>148</td>
</tr>
<tr>
<td>11.2</td>
<td>How to Use the Network File System (NFS)</td>
<td>151</td>
</tr>
<tr>
<td>11.2.1</td>
<td>A Brief Description of the Network File System NFS</td>
<td>151</td>
</tr>
<tr>
<td>11.3</td>
<td>How to Use Windows Shares</td>
<td>152</td>
</tr>
<tr>
<td>11.3.1</td>
<td>Preliminary Note</td>
<td>152</td>
</tr>
<tr>
<td>11.3.2</td>
<td>Accessing Shares and Other Services</td>
<td>153</td>
</tr>
<tr>
<td>11.4</td>
<td>How to Share Files with Novell iFolder</td>
<td>155</td>
</tr>
<tr>
<td>11.4.1</td>
<td>What Is Novell iFolder</td>
<td>155</td>
</tr>
<tr>
<td>11.4.2</td>
<td>Configure iFolder</td>
<td>156</td>
</tr>
<tr>
<td>11.4.3</td>
<td>Use iFolder</td>
<td>158</td>
</tr>
<tr>
<td>11.5</td>
<td>How to Manage CDs</td>
<td>162</td>
</tr>
<tr>
<td>11.5.1</td>
<td>Starting K3B</td>
<td>162</td>
</tr>
<tr>
<td>11.5.2</td>
<td>Create a New Audio or Data CD</td>
<td>163</td>
</tr>
<tr>
<td>11.5.3</td>
<td>Copy a CD</td>
<td>166</td>
</tr>
<tr>
<td>11.5.4</td>
<td>More Tools</td>
<td>167</td>
</tr>
</tbody>
</table>

### 12 Manage Novell Linux Desktop

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.1</td>
<td>How to Use root</td>
<td>170</td>
</tr>
<tr>
<td>12.1.1</td>
<td>What root Is</td>
<td>170</td>
</tr>
<tr>
<td>12.1.2</td>
<td>Describe When to Use root</td>
<td>170</td>
</tr>
<tr>
<td>12.1.3</td>
<td>How to Log In as root From the Desktop</td>
<td>171</td>
</tr>
<tr>
<td>12.2</td>
<td>How to Manage Processes</td>
<td>172</td>
</tr>
<tr>
<td>12.2.1</td>
<td>Describe What a Process in a Linux System Is</td>
<td>172</td>
</tr>
<tr>
<td>12.2.2</td>
<td>Useing Tools to Terminate Processes</td>
<td>173</td>
</tr>
</tbody>
</table>
Appendix

A Alternatives for Windows Applications
   A.1 Office Applications
   A.2 Internet Applications
   A.3 Data and File Management Applications
   A.4 Multimedia Applications
   A.5 Publishing Applications

B Detailed Network Configuration for Novell Linux Desktop
   B.1 When to Configure
   B.2 Change the Network Configuration
      B.2.1 Select a Network Card
      B.2.2 Change the IP address
      B.2.3 Change the Host Name
      B.2.4 Change the Default Gateway

C Detailed Configuration of the Print Management CUPS
   C.1 When to Configure
   C.2 Change the Printer Configuration

List of Figures

List of Tables
General Information

Fonts

The following table shows the typographic conventions used in this training manual and their meanings.

<table>
<thead>
<tr>
<th>Font</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example</td>
<td>File names, paths</td>
<td>In the directory /home/...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the file /etc/fstab...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the command ls...</td>
</tr>
<tr>
<td>Variables</td>
<td></td>
<td>... content of DISPLAY...</td>
</tr>
<tr>
<td>Buttons, text fields, radio buttons, etc.</td>
<td>After clicking OK...</td>
<td>In the field User, enter ...</td>
</tr>
<tr>
<td>Program output and input</td>
<td>tux@earth:~ &gt;</td>
<td>... enter yes...</td>
</tr>
<tr>
<td>URLs</td>
<td></td>
<td><a href="http://www.suse.com">http://www.suse.com</a></td>
</tr>
<tr>
<td>Daemons</td>
<td></td>
<td>named makes sure that...</td>
</tr>
<tr>
<td>Example</td>
<td>Highlighting</td>
<td>... may not...</td>
</tr>
<tr>
<td>User, host, and domain names</td>
<td>... to the user tux ...</td>
<td>... to the host earth ...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>... via sun.example.com ...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>... hosts in the network example.com ...</td>
</tr>
<tr>
<td>Example</td>
<td>Placeholder</td>
<td>ping hostname</td>
</tr>
<tr>
<td>[Example]</td>
<td>Optional parameters</td>
<td>ls [-la]</td>
</tr>
<tr>
<td>[Example]</td>
<td>Optional placeholders</td>
<td>su - [login]</td>
</tr>
<tr>
<td>(Example)</td>
<td>Keyboard key</td>
<td>... pressing (Ctrl)(X)...</td>
</tr>
</tbody>
</table>
Symbols

The symbols used in the manual are explained in the following table:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>✏</td>
<td>Exercise</td>
</tr>
<tr>
<td>★</td>
<td>Note</td>
</tr>
<tr>
<td>☑</td>
<td>Optional supplement</td>
</tr>
<tr>
<td>⚡</td>
<td>Warning</td>
</tr>
</tbody>
</table>
1 Introduction

This kit provides a step-by-step introduction to the Novell Linux Desktop which comes, out of the box, with a rich set of applications. After you complete this kit, you can decide for yourself if Linux is a valid alternative for you. If you decide to implement Linux, this kit provides the information you need to make the switch to Linux.

This study kit is for students who are familiar with Windows desktop systems. If you are already familiar with a different Linux distribution and want to have a closer look at the Novell Linux Desktop, simply skip the information you are already comfortable with and focus on how Novell Linux Desktop differs from your current desktop solution.

Objectives

After you complete this chapter, you should be able to do the following:

• Describe how to use this kit to learn about using Novell Linux Desktop on your desktop computer.

• Select the best option for downloading or ordering the software needed to complete this kit successfully.
1 Introduction

1.1 Purpose of This Kit

This kit assumes that you are familiar with one or more Microsoft Windows desktop systems. You should be:

- Able to navigate the Microsoft Windows desktop.
- Familiar with Microsoft Office.
- Familiar with other common Windows applications.

This kit also assumes that you are working on an existing network where base services such as DHCP, DNS, and file and print services are up and running. If you are using a standalone computer, the Appendix provides a simplified network and printer setup.

If you use specialized applications on your Microsoft desktop, refer to the Appendix which has a list of alternative, Linux-based programs. This list is not all-inclusive. For special needs, you can search the Internet. You should be able to find alternatives for the Linux platform ranging from free open software to commercial products.

With this kit, you can learn about the benefits of using Linux as a desktop system in just one day. You will even be able to see how your own Microsoft Office files work in the Linux environment.

1.2 Download Zone

The kit is based on the Novell Linux Desktop. For your convenience, we have made several options available for you to get the software needed to complete the hands-on exercises in this study kit. You can either download a free evaluation copy from the Web or purchase Novell Linux Desktop.

On the Web site where you downloaded this study kit, you find all the links and information needed to obtain the software.

The main download site is

http://www.novell.com/maketheswitch

This PDF file can be distributed freely. If you downloaded this kit, you were given the option to provide your e-mail address and other information that will allow us to update you on the future Novell software developments and Novell Training Services offerings. To receive this information,
each user must download the PDF file individually and provide his or her contact information. Regardless of how you obtained this file, you will still need the software discussed above to complete the exercises.

**Summary**

- With this kit and the Novell Linux Desktop, you can decide if the Linux system is a good alternative for you.

- With the options on the web page where you downloaded this file, you can download or purchase Novell Linux Desktop software; providing you with everything you need to complete this study kit.
2 Describe the Unique Characteristics of Linux

Objectives

After you complete this chapter, you should be able to do the following:

• Briefly describe the history of Linux and the differences between Linux and other operating systems.

• Describe the main differences between a Linux system and a Microsoft Windows system.
2 Describe the Unique Characteristics of Linux

2.1 What Linux Is

2.1.1 A Brief History of Linux

In the 1980s and early 1990s, a clear division existed between expensive departmental computers, normally running a UNIX operating system with commercial applications, and inexpensive personal computers (PCs). To combine the advantages of UNIX computers (stability and high performance) with the PC (low-cost hardware), developers began trying to develop a system similar to the UNIX operating system that would run on PC hardware. (The Intel 80386 processor became available during this time period.)

In 1991, Linus Torvalds, a Finnish student, created a PC operating system similar to UNIX. He named it Linux and published it on the Internet. From the beginning, Linux has been freely available, a decisive factor in its success. As a result, interested programmers worldwide can contribute to its further development.

Because of the way it was published and licensed, no one can buy the ownership rights of Linux. Likewise, no one can charge licensing fees for the use of this operating system (they can charge licensing fees for commercial applications that are run on Linux).

2.1.2 What a Linux Distribution Is

The Linux operating system consists of the actual core or kernel and a large number of additional user programs. These programs are needed for secure and convenient operation. Various application programs are usually installed on a computer. To use other operating systems, you usually have to purchase application programs. The majority of application programs for Linux, however, are either freely available or can be used free of charge. Linux can therefore be considered a package, an operating system with many application programs that are available free of license fees. Although you can obtain all of these Linux-based programs via the Internet, doing so involves downloading huge amounts of data. It makes sense, then, to store the Linux operating system, together with all the free user programs, on CD or DVD. Such a collection, or distribution, offered by various commercial companies, usually includes (in varying size and quality) printed installation instructions and installation programs, some of which are very sophisticated. While the price of these distributions is justified by the costs of producing a CD and providing the installation aids to make Linux available to most users, it does not include licensing fees. You do not need a license for Linux when you purchase a distribution, and after you have purchased the distribution, you can install it on any number of computers. The question of pirated copies also does not arise.
You should be familiar with the following terms:

- The Linux kernel is the system core. It provides the technology to interact with the computer hardware and to allow higher applications to make use of the computer hardware.

- A Linux Operating System is a combination of the Linux kernel and installation and configuration programs simplify using Linux technology to operate a computer.

- A Linux Distribution is a combination of a kernel, the components needed to make up the operating system, and enough applications to create a full working environment. Not only do distributions come from different vendors such as Novell, but most vendors also make different distributions available for special purposes. A Linux distribution can have 1,000 to 5,000 bundled applications.

- The term “Linux Server” is not clearly defined, but most vendors use the Linux server as a stable, reliable platform on which a company can run mission-critical services or applications in a corporate network. In this scenario, having the latest technologies is not as important as having the most reliable ones bundled with each server version. A server version has a much longer product roll-over period than desktop distributions, and is built only with reliable components. In addition, support services can be granted to server distributions running any application on top as long as the kernel has not been modified.

- Any kind of desktop system should serve the defined needs of a desktop computer user. This kit is built on the Novell Linux Desktop, a User Desktop system with a more limited number of easy-to-use applications that take advantage of the full processing power of a computer. This edition comes with a full version of OpenOffice, the free Office application, and basic communication applications.

### 2.2 Major Differences Between Windows and Linux

Linux and Windows are different. So many differences exist that we cannot describe all of them here. However, we can discuss some of the major differences.

#### 2.2.1 Linux Is Case Sensitive

Linux differentiates between lower-case and upper-case characters for filenames. The files `hello.txt`, `Hello.txt` and `HELLO.TXT` are totally different and can coexist in one directory.
2 Describe the Unique Characteristics of Linux

2.2.2 Slash Instead of Backslash

When you enter a path in Windows, you divide the directories and the filename with a backslash “\” (for example: C:\WINNT\explorer.exe). In Linux, you have to use the slash “/” instead, just as you do in Internet addresses.

2.2.3 There Are No Drive Characters in Linux

In Windows, every storage device is named with a special character (for example, the floppy disk drive is named “A:” and the hard disk is named “C:”…).

In Linux, the storage devices do not have naming characters. You have only one file system tree that includes all devices. The devices are mounted in this tree and appear as a directory to the user. As administrator, you can choose where to mount the devices and what to name them (normally the floppy disk drive is listed under /media/floppy/).

This system allows you to use more than 26 storage devices at the same time. Additionally, the user does not need to know whether the file he is looking for is on the first, the second, or the third hard disk.

2.2.4 There Are No EXE Files

In Windows you can identify an executable file by the extension .exe. In Linux executable files do not have this extension (many files do not have any extension). You can identify executable files in Linux by their permissions. If the “execute” permission is set, you are allowed to execute the file.

2.2.5 The Graphical User Interface Is Not a Part of the Operating System

You cannot install Windows without its graphical user interface. In Linux, the graphical user interface is a normal application that you can choose whether or not to install. Because the most important server services in Linux can be configured by editing an ASCII text file, you do not need a graphical front end if you want your computer to act only as a server.
2.2 Major Differences Between Windows and Linux

Not installing a graphical user interface has some advantages:

**Stability** Every program includes errors that can make your system unstable. The fewer number of programs you use, the more stable your system will be. A graphical user front end is a large program and it may contain a lot of undiscovered programming errors, even if the error ratio is low.

**Performance** Every running program needs system resources. Fewer programs running on your computer means increased performance.

**Variety** A lot of different graphical user interfaces are available for Linux. You can use more than one and you can choose which one you like most.

### 2.2.6 The Administrator Is Called root

A Linux system has only one administrator account. The administrator, which is called root, can delegate tasks to users, but a user cannot be identical to root.

Microsoft Systems also has an administrator account. The account has all privileges and is not used by normal users by default.

### 2.2.7 More Than One Company Is Developing Linux

Linux is being developed by multiple companies. In additions, many companies and individuals are developing products for Linux.

### 2.2.8 Linux Comes Bundled with Many Applications

Thousands of applications are available for Linux. Many of them are already bundled in the distribution. The Novell Linux Desktop includes the operating system, which is installed along with the other applications that come bundled with it on the CD. These applications can include the whole OpenOffice suite, collaboration programs, and tools for burning CDs. With Microsoft Windows, you must purchase and install most applications separately.
2 Describe the Unique Characteristics of Linux

Summary

- Linux is a license-free, ongoing project with contributions from many sources rather than a single vendor system sold for a license fee.

- Linux desktop distributions provide a real alternative to proprietary systems such as those from Microsoft. Linux is already well accepted in the server arena for special-purpose servers.

- The main differences between Microsoft Windows systems and Linux can be easily understood.
3 Linux Installation and Components

Objectives

After you complete this chapter, you should be able to do the following:

• Describe the components of the Novell Linux Desktop distribution and choose the best option for studying this kit.

• Understand the whole installation process of Novell Linux Desktop and successfully install the distribution on your test hardware.

• Install Novell Linux Desktop to establish your learning environment.
3 Linux Installation and Components

3.1 Novell Linux Desktop Components

The Novell Linux Desktop distribution includes 4 CDs or 1 DVD.

The distribution also includes an installation guide that describes the installation and the main applications and lists a unique code allowing you to register with Novell Support for free Installation Support of Novell Linux Desktop on your computer.

Information on how to obtain the Novell Linux Desktop components needed to use this kit is given in Chapter 1.2 on page 4.

3.2 How to Install Novell Linux Desktop

3.2.1 Novell Linux Desktop Installation Methods and Tools

The installation and configuration program for Novell Linux Desktop is called YaST (Yet another Setup Tool).

You have several options to choose from when installing Novell Linux Desktop:

Manual You can install Novell Linux Desktop from CD or DVD.

Network It is easy to configure an installation server in your network. You only need a boot medium (such as a floppy or CD); the packages are installed from the network.

Automatic The Novell daughter company SUSE Linux developed a tool that allows Novell Linux Desktop to be installed and configured automatically. This tool is called AutoYaST.
3.2 How to Install Novell Linux Desktop

3.2.2 The Start Screen

![The Boot Menu](image)

Figure 3.1: The Boot Menu

After you boot your computer from the installation CD, the welcome screen appears (see Figure 3.1). You can then choose which installation option you want. The options are described below:

**Boot from Hard Disk** Boots the standard operating system installed on your hard disk.

**Installation** Starts the normal installation process.

**Installation - ACPI Disabled** Some old computers don’t have ACPI power management. This can lead to problems during the installation. With this kind of installation, you can disable the ACPI features of Novell Linux Desktop.
Installation - Safe Settings Some older computers don’t have any kind of power management or hard disk acceleration. If you have problems with your installation, you should try this.

Rescue System A minimal Linux (without a graphical user interface) starts from the CD and allows you to repair the Linux installation on the hard disc.

Memory Test Tests the RAM of physical errors.

If you do not type any key within eight seconds, the system will boot from your hard disk and start your already installed OS. Use the arrow keys to select the option you want and press \( \text{Enter} \).

When you select one of the first installation options and press \( \text{Enter} \), the installation program – called YaST – starts.
3.2 How to Install Novell Linux Desktop

3.2.3 Base Installation

First of all, you have to read the Novell Software agreement. Select I Agree.

The first screen of YaST asks you for the language to be used during the installation process (see Fig. 3.2).

![Image of YaST language selection]

Figure 3.2: Language for the Installation Process

Click Accept to bring up the next dialog (see Figure. 3.3 on the next page).
In contrast to other operating systems, such as Windows or Mac OS, the graphical user interface (GUI) is not an inherent part of the operating system. In Linux you have the choice between dozens of GUIs. The Novell Linux Desktop includes only the most important two: GNOME (Figure 2.4) and KDE (Figure 2.5).
3.2 How to Install Novell Linux Desktop

**GNOME**

![GNOME User Interface](image)

Figure 3.4: The GNOME User Interface
3 Linux Installation and Components

KDE

Figure 3.5: The KDE User Interface

Both are very similar to the Windows look and feel. Both have their weaknesses and strengths. In this training we will concentrate on the GNOME GUI.

After clicking Accept, the following dialog appears.
3.2 How to Install Novell Linux Desktop

YaST shows you information about your hardware and makes suggestions for the installation. You can change these by clicking on the head font of each of the sections or by using the Change... menu.

The following sections are defined:

**System** Lists details about your hardware.

**Mode** Lists the available installation modes.

**Keyboard layout** Identifies the layout of your keyboard.

**Mouse** Identifies your mouse type.

**Partitioning** Lets you create and change the partitioning table of your hard disk.

**Software** Lets you select the software to be installed.

**Booting** Lets you install and configure the GRUB boot loader.
3 Linux Installation and Components

**Time zone** Lets you select your time zone.

**Language** Lets you select the default language for your installation.

**Default Runlevel** Lets you select the default Runlevel for your system. Runlevels are different modes your system can work in. In Runlevel 5 the system allows normal users to log in, is configured to use network services, and automatically starts the graphical user interface.

Normally you do not need to change the recommendations made by YaST. This is especially true if your test system has a blank hard drive. If you already have another operating system installed on the computer but your hard drive has free, unpartitioned space left, YaST automatically recommends installing Novell Linux Desktop in that free space and creating a dual boot configuration for both operating systems.

After clicking Accept, you need to confirm your settings again. Selecting Yes, install starts the installation process. This can take some time, depending on your hardware.
3.2 How to Install Novell Linux Desktop

3.2.4 Configuration

Root Password

If the installation was successful, the computer reboots. YaST starts up again because you need to configure some basic settings.

The first thing you need to do is to specify the password for the administrator root.

Figure 3.7: Specify the root Password

A warning appears if the selected password is too simple.
Network Configuration

After you have specified a password, you review your network configuration. YaST displays a summary of the network devices it has discovered:

- Network Interfaces
- DSL Connections
- ISDN Adapters
- Modems
- Proxy

![Figure 3.8: Network Configuration]
3.2 How to Install Novell Linux Desktop

For network interfaces YaST selects by default the automatic network configuration via DHCP. You can change the network configuration by clicking on the headline of the section or by using the Change... menu. If you want to change the network configuration, please read Appendix B on page 205 first.

In the next screen, you can test your internet connection. If you select Yes, Test Connection to the Internet, the latest release notes will be downloaded and YaST will check for new updates.

![Figure 3.9: Test the Network Configuration](image)

If new updates are found, YaST asks you to verify the download and installation. You should apply any updates to ensure your new system has the latest patches applied.
Users

Before you can add users to the system, you have to choose an authentication method. If you are using your Linux computer in a network with an NIS or LDAP authentication server, you can select NIS or LDAP in the next screen. Otherwise, you can select Local (/etc/passwd) and add the users of your computer manually.

Figure 3.10: Select the User Authentication Method

To add a user, you need to provide the following information:

**Full User Name** The full name of the user.

**User Login** The login name of the user. This name must be unique on the system.

**Password** The case-sensitive login password for the user. You have to enter the password twice for verification.\(^1\) YaST displays a warning if the password is insecure.

\(^1\)For security reasons, the letters of the password are shown as asterisks.
3.2 How to Install Novell Linux Desktop

If you want the user to receive automatically generated mail intended for the root user account, activate the Receive System Mail option.

If you use your Linux computer only at your own desk and you want to avoid the login during the startup, you can activate the Auto Login option (not recommended).

The system information is now written to disk. YaST opens a window with the release notes.
3 Linux Installation and Components

Figure 3.12: The Release Notes

Hardware Configuration

The last items you need to configure are additional hardware items such as

- Graphics Card
- Printer
- Soundcard
- TV cards

The graphics card and the soundcard are configured automatically by YaST. Most printers are also detected automatically. If you want to change the printer configuration, please read Appendix C on page 213. Click Next to confirm the settings and write them to the system.
3.2 How to Install Novell Linux Desktop

Figure 3.13: The Hardware Configuration

The last dialog tells you that the installation was successful. Select Finish. Novell Linux Desktop is now ready for use.

**Exercise: Install Novell Linux Desktop**

You are ready to apply your knowledge about the Novell Linux Desktop installation to your test system. For this exercise you should have a test system with a blank hard drive or enough free, unpartitioned space to install Novell Linux Desktop.

1. Insert the Novell Linux Desktop Installation CD or DVD into your CD/DVD drive.
2. Reboot your computer.
3. Select Installation from the installation menu.
4. Accept the License Agreement by clicking I Agree.
5. Select English (US) in the language menu and click Accept.
6. Select GNOME as your graphical environment and click Accept.
7. If you do not have a US keyboard, complete the following:
   - Select Keyboard layout.
   - Select the country of your keyboard layout.
   - Click Accept.
8. Accept the installation suggestions by clicking Accept.
9. Confirm the installation settings by clicking Yes, install.
10. Go for a coffee. :-)
11. To specify the root password, enter novell in the two text fields; then click the Next button. Confirm the warning messages by clicking Yes.²
12. Confirm YaST’s network configuration suggestions by clicking Next.
13. Select Yes, Test Connection to the Internet and click Next to test your connection.
14. If the connection test was successful, click the Next button.
15. Do not install the updates found. Select No, Skip Update and click OK.³
16. Select Local (/etc/passwd) as the user authentication method and click Next.
17. Add your first user. Insert the following data:

<table>
<thead>
<tr>
<th>Textfield</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full User Name</td>
<td>Tux Penguin</td>
</tr>
<tr>
<td>User Login</td>
<td>tux</td>
</tr>
<tr>
<td>Password</td>
<td>novell</td>
</tr>
<tr>
<td>Verify Password</td>
<td>novell</td>
</tr>
</tbody>
</table>

Confirm the warning messages by clicking Yes.
18. Confirm the release notes by clicking the Next button.

²You should use this insecure password only for the purpose of this training. Choose a more secure password on a live system.
³You should install the updates on production systems. You shouldn’t install the updates during training because the updates may change menus and user interfaces.
3.2 How to Install Novell Linux Desktop

19. Confirm the hardware configuration dialog by clicking Next.
20. When the installation is complete, click Finish.

At this point you should have successfully installed your Novell Linux Desktop on your test computer.

Summary

• You are familiar with the components of the Novell Linux Desktop.
• You are familiar with the different screens and installation options.
• You have successfully installed Novell Linux Desktop on your test system as a stand-alone desktop system using standard options and having access to the Internet and printers (if applicable).
3 Linux Installation and Components
4 Explore and Configure the GNOME Desktop

Objectives

After you complete this chapter, you should be able to do the following:

- Understand how to safely boot and shut down your computer in the GNOME desktop environment on a system running Novell Linux Desktop.
- Describe the GNOME desktop environment and tools and use them to become familiar with the system.
- Explore your new system’s default GNOME desktop environment in a structured exercise.
4.1 How to Log In and Log Out of the GNOME Desktop

4.1.1 Logging In

If computer users want to work with a multiuser-capable operating system, they must first identify themselves to the operating system. For this purpose, individual users are given unique names called a *login string or user name*. Only authorized users should be allowed to log in. Along with the unique name, each user is given a unique password. When a new user is added, the system administrator will usually assign a password (unless none has yet been given).

When the computer is booted and ready for work, the login mask appears (see Fig. 4.1).

![Login Mask](image)

**Figure 4.1: The Login Mask**

In the *Username* field, enter the login name of the user. After pressing `Enter`, the label of the text box switches to *Password* and you can enter the password assigned to the user. To finish the log-in process, press `Enter` again.
4.1 How to Log In and Log Out of the GNOME Desktop

If the system login was successful, the GNOME desktop environment will be launched after a few seconds.

Figure 4.2: The GNOME Work Environment

4.1.2 Logging Out

When you are ready to log out of the system, you have to open the System menu in the top panel. At the bottom of the System menu (see Fig. 4.3 on the next page), locate the Log Out User Name entry.
If you click Logout User Name, a confirmation dialog (see Figure 4.4 on the facing page) asks which option you want to use.

**Log out**  If you select this item and click the OK button, the GNOME session will be closed. The login screen (see Fig. 4.1 on page 34) will appear, allowing you or another person to log in.

**Shut down**  If you select this item and click the OK button, your session will be closed and the computer will shut down.

**Restart the computer**  If you select this item and click the OK button, your session will be closed and the computer will reboot.

The option Save current setup saves the settings of open windows. On the next login, the system will reinstate the window settings you’ve configured in the current session.
4.2 How to Shut Down and Reboot the Linux System

If you are at the login screen (see Figure 4.1 on page 34), you can shut down or reboot your computer by opening the Menu menu and selecting one of the following options:

**Language** You can select the language of your GNOME desktop.

**Session** You can choose another window manager than GNOME. For the simplicity of this study kit, we will cover the GNOME environment only.

**Actions** Selecting this option makes a dialog appear, where you can choose (see Fig. 4.5 on the next page):

- **Shut down the computer** Linux will close all the (system) programs currently running.
  Older computers that do not have power management and cannot switch themselves off can be switched off by the user when the following message appears:

  > Master Resource Control: runlevel 0 has been reached

  If you switch the machine off too soon, you could possibly lose data.
4 Explore and Configure the GNOME Desktop

Reboot the computer Reboots your computer.

Run XDMCP chooser You can select another computer in your network to login.

Configure the login manager After entering the password of the user root the configuration dialog for the login manager appears.

⚠️ Attention! You should always shut down your computer before you turn it off.

![Figure 4.5: Shutting Down Linux Before Switching Off](image.png)

4.3 The GNOME Desktop and Windows

After you log in, your system will by default start the GNOME desktop environment. It is composed of three main parts:

- the desktop
- a panel at the top of the desktop, called Top Panel, and
- a panel at the bottom, called Bottom Panel.
4.3 The GNOME Desktop and Windows

4.3.1 Desktop

On the desktop you will see only a few icons. You can start the applications associated with these icons by double clicking them with your left mouse button.

You can move the icons by dragging them with the mouse.

4.3.2 Top Panel

The Top Panel (Figure 4.6) includes the most important menus and functions for working with the GNOME desktop.

![Figure 4.6: The Top Panel](image)

The items and icons are explained below (from left to right).

- The Programs menu includes starters for the most important programs.
- The System menu includes more administrative functions like configuring the system, searching files, and logging out.
- The Help menu includes a link to the Novell Linux Desktop Help Center.
- A single click on the globe with a red fox icon starts the web browser Firefox.
- The yellow button with a calendar and envelope starts the groupware client Evolution.
- The grey button with birds and a pen starts the word processor of the office suite OpenOffice.org.
- Next to the small grey bar is the “Panel Notification Area.” This panel can show the state of system programs running in the background. You can compare the Panel Notification Area to the system tray of Windows.
4.3.3 Bottom Panel

The main area of the bottom panel is reserved for the “Window List.” All open windows are shown in this list. Here you can open a window you minimized previously. You can compare it to the Windows task bar.

If you are working with a number of programs concurrently, the screen may quickly become cluttered with open windows, causing confusion. In Linux, you can bring order to this chaos by changing to another (virtual) desktop. You can switch between the various desktops via the four grey boxes in the bottom panel. Every virtual desktop can host a practically unlimited number of applications. Using these virtual desktops, you can easily organize your work.

The icon left to the four grey boxes at the right corner of the bottom panel minimizes all opened windows at the actual desktop.
4.3 The GNOME Desktop and Windows

4.3.4 The Programs Menu

Programs are normally started from the Programs menu. You can click the menu label to open the Programs menu.

A submenu in a menu is marked by a small black arrow to the right (see Figure 4.8). The entry does not need to be clicked for it to open. Just move the mouse cursor over the menu entry. To start a program, click once with the mouse on the corresponding entry.
4.3.5 The Clipboard

When you are composing a document, you may want to use existing text. For example, you might be writing a letter with a word processor and decide that you want to quote a paragraph from an Internet page. To avoid typing this text again, you can use the clipboard.

To copy text into the clipboard, highlight the desired text by holding down the left mouse button and moving the cursor.

To insert the copied text, set the mouse cursor at the desired insertion point; then middle-click to paste. On a 2-button mouse, you can press the left mouse button and the right mouse button at the same time to simulate the middle mouse button.

4.3.6 Managing Icons

Desktop

You can create a new icon on your desktop in several ways. For simplicity, we will describe only one method.

To create an icon for an application on your desktop, select the item in your Programs menu. Hold down the left mouse button, move the mouse cursor to free space on your desktop and release the mouse button.

To remove a desktop icon, click it with the right mouse button and select Move to Trash.

Top or Bottom Panel

You can add new programs to a panel by right-clicking on a free area of the panel and then selecting Add to Panel. A menu opens. You can find all entries of the Programs menu at Launcher from menu.

You can remove a program from the control panel by right-clicking its icon in the control panel and then selecting Remove From Panel. You can move icons in the panel by holding down the middle mouse button or by choosing Move from the Context menu.
4.3 The GNOME Desktop and Windows

Programs Menu

To make changes in your Programs menu, you must first select Personal Settings from the System menu. You can edit the menu by clicking the Menus icon in the Personal section.

![Personal Settings Menu](image)

Figure 4.9: The Personal Settings Menu

4.3.7 Managing Windows

Every window displays its operating elements in the top margin (see Figure 4.10 on the following page). After clicking the leftmost symbol, a context menu for the window manipulation opens. Close a window by clicking the “X” symbol on the far right. Click the square symbol next to it to make the window fill the entire screen. Click the line next to it to reduce, or minimize, the window to symbol size in the window list of your bottom panel without closing it (and without ending any programs that may be running in it).
Explore and Configure the GNOME Desktop

To move the entire window without changing its size, click the titlebar of the window with the left mouse button and hold the mouse button down. You can now move the window.

To change the size of a window, move the mouse cursor to the edge of the window to move until the cursor changes its shape. Then click the edge of the window and change the size. If you move the mouse cursor over the corner of the window, the mouse cursor changes to a diagonal arrow that you can use to change the size of the window both horizontally and vertically.

Right-clicking the titlebar of the window opens a menu providing the same options as the icons in the panel (moving, sizing, minimizing, maximizing). Select On Top to keep the window in the foreground so that it cannot be covered by any other window. The menu entries at the bottom of the menu can be used to move the window other virtual desktops.

Exercise: Explore Your KDE Desktop

After this quick introduction, you are ready to explore your KDE environment with the following exercise.

1. Start your computer.
2. Enter your login name (tux) in the Username textbox and press Enter.
3. Enter your password in the Password textbox and press Enter. For security reasons, asterisks are displayed instead of the actual letters when you enter the password.
4. Open the System menu in the top panel.
6. Click OK.
7. Open the Actions menu.
8. Select Reboot the computer and click OK.
9. After the computer has restarted, you will see the login window again. Enter your username in the Username textbox and press (Enter).
10. Enter your password in the Password textbox and press (Enter).
11. Start the Novell Linux Desktop Help Center by selecting Help → User’s Manual in the top panel.
12. Highlight the text line (“Table of Contents”) by moving the mouse cursor over it with the left mouse button held down.
13. Switch to the second virtual desktop by clicking the second grey box in the bottom panel.
14. Start a standard editor from the Programs menu (Accessories → Text Editor).
15. Press the middle mouse button (or press the right and left mouse buttons simultaneously on a 2-button mouse) over the white editor text area and insert the buffered text.
16. Save the text (File → Save As...) with the myfile file name. To do so, insert myfile in the Name text field. Make sure that Home is activated in the menu Save in folder and click Save.
17. Move the editor window to the first virtual desktop by right-clicking on the titlebar and select Move to Another Workspace → Workspace 1.
18. Switch back to the first virtual desktop.
19. Close the editor.
20. Move the Novell Linux Desktop Help Center window and change its size.
21. Maximize the window.
22. Close the window.
4.4 How to Modify the GNOME Environment

GNOME provides a very convenient tool (see Figure 4.11) for changing the appearance and function of the desktop. You can start this tool by selecting System menu → Personal Settings.

The functions in the Control Center are summarized in four categories:

- Personal
- Appearance
- Hardware
- System

Every category consists of subcategories. Double click a subcategory name or icon to access a configuration dialog. You do not need to activate your changes. Just click Close to close the dialog.

Figure 4.11: The Personal Settings Menu
The most important settings are listed below.

### Personal

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessibility</td>
<td>Basic: Key repetition&lt;br&gt;Filters: Beep on pressing special keys (e.g., shift lock)&lt;br&gt;Mouse Keys: Control the mouse cursor by the cursor keys</td>
</tr>
<tr>
<td>Assistive Technology Support</td>
<td>Activate a screen reader, magnifier or on-screen keyboard</td>
</tr>
<tr>
<td>Menus</td>
<td>Manage the entries in the Programs menu</td>
</tr>
<tr>
<td>Shortcuts</td>
<td>Associate keyboard shortcuts with functions</td>
</tr>
</tbody>
</table>

Table 4.1: Personal Settings: Personal Category

### Appearance

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop Background</td>
<td>Background color and wallpaper</td>
</tr>
<tr>
<td>Fonts</td>
<td>Fonts used on the desktop</td>
</tr>
<tr>
<td>Screensaver</td>
<td>Type and activation parameters for the screensaver</td>
</tr>
<tr>
<td>Theme</td>
<td>Arrangement: Color and style of the windows</td>
</tr>
<tr>
<td>Windows</td>
<td>How to activate a window and the meaning of a double-click on the title bar.</td>
</tr>
</tbody>
</table>

Table 4.2: Personal Settings: Appearance Category
4 Explore and Configure the GNOME Desktop

Hardware

<table>
<thead>
<tr>
<th>Category</th>
<th>Settings</th>
</tr>
</thead>
</table>
| Keyboard       | Keyboard: Repeat keys  
                 | Layouts: Keyboard layout                                                 |
| Mouse          | Buttons: Mouse orientation, speed of double-click                        |
|                | Cursors: Size of mouse cursor                                           |
|                | Motion: Speed                                                            |
| Printers       | Overview of available printers                                           |
| Screen Resolution | Switch to another resolution (if configured)                           |

Table 4.3: Personal Settings: Hardware Category

System

<table>
<thead>
<tr>
<th>Category</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Associations</td>
<td>File type associations</td>
</tr>
<tr>
<td>Network Proxies</td>
<td>Configure the network proxy (not necessary if you use the Firefox web browser)</td>
</tr>
<tr>
<td>Sessions</td>
<td>Session Options: Manage window sessions (you can select a session later on the login dialog)</td>
</tr>
<tr>
<td></td>
<td>Startup Programs: Start a program automatically after the login</td>
</tr>
<tr>
<td>Sound</td>
<td>Sound Events: Play sounds at special events</td>
</tr>
<tr>
<td></td>
<td>System Bell: Enable audio and visual feedback</td>
</tr>
</tbody>
</table>

Table 4.4: Personal Settings: System Category

©2004 Novell Inc., the leading provider of Information Solutions
Exercise: Modify Your GNOME Desktop Environment

This exercise will introduce you to the basics in customizing your workspace in the GNOME environment.

1. Start the configuration tool by selecting System → Personal Settings.
2. Double-click Fonts in the Appearance section.
3. Click the button next to Window title font.
4. Switch Size to 18 and click OK.
5. Close the dialog by clicking Close.
6. Select the screensaver configuration mask by double clicking on Screensaver in the Appearance section.
7. Change the active screensaver to Noof.
8. Close the screensaver dialog.
10. Click the button next to Window title font.
11. Switch Size back to 10 and click OK.
12. Close the dialog by clicking Close.
13. Close the setting window.

4.5 How to Access a Command Line from Within GNOME

The command prompt of the operating system is available even when you are using the graphical desktop. Other programs such as Terminal (the default in GNOME) or xterm provide access to the command prompt in the X Window System. To start Terminal select System Tools → Terminal in the Programs menu.
Occasionally you may need to run just a single command. Perhaps you want to start a program you cannot find in the Programs menu. A command line exists for such cases. You can access the command line in the System menu by selecting Run Program....

Enter the command in the text line. The command will be executed when you click Run. If you want to start a program without a graphical user interface, you have to activate the checkbox Run in terminal.
4.6 How to Change Your Password

You can use the passwd utility to change passwords. This tool is a command line tool. To access this you have to open a terminal window and enter passwd.

First, enter your old password. Then enter the new one twice. For reasons of security, the password here remains invisible. In addition, passwords that are too short or too simple are not accepted. After you type the new password the second time, the program changes the corresponding entry in the system.

tux@da1:~> passwd
Changing password for tux.
Old Password: 
New password: 
Re-enter new password: 
Password changed

Exercise: Changing Your Password

Now, you will change your password in this quick exercise.

1. To start Terminal select System Tools → Terminal in the Programs menu.
2. Enter passwd to start the password utility.
3. Enter your old password novell.
4. Enter as new password penguin. You should get the message Bad password: too simple.
5. Enter as new password d1g1tal!.
6. For verification, you have to enter d1g1tal! a second time. You should get the message that your password is changed.
7. Close Terminal.
8. Click with the right mouse key on an empty space on your desktop.
9. Select Create Launcher to create a new starter.
4 Explore and Configure the GNOME Desktop

10. Enter the following data into the dialog:

<table>
<thead>
<tr>
<th>Text field</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Change Password</td>
</tr>
<tr>
<td>Generic name</td>
<td>Change Password</td>
</tr>
<tr>
<td>Comment</td>
<td>With passwd you can change your password</td>
</tr>
<tr>
<td>Command</td>
<td>passwd</td>
</tr>
</tbody>
</table>

11. Click the icon button, select the icon gnome-ccdialo.png from the dialog and click OK.

12. Activate the Run in terminal checkbox.

13. Click OK. A new icon should appear on the desktop.

14. Double click on the new icon. Terminal should open and run passwd, which prompts you for your old password.

15. Close Terminal.

You now have successfully changed your password. Be sure to remember that Linux passwords are case sensitive and that you now have a password of d1g1tal! with all lowercase letters.

Summary

- You can safely bring your Linux system up and shut it down.
- You can log in and log out of the system.
- You are familiar with the basic concepts of the GNOME desktop environment.
5 Manage the Linux File System

Objectives

After you complete this chapter, you should be able to do the following:

• Describe the Linux file system and be able to store and find files you create on your Linux system.

• Understand the main principles of access control in the Linux file system and be able to apply security to your files.

• Describe how to work with files on a Linux system and be able to create your own working space on your system.

• Describe how to work with removable devices such as CD-ROM drives or floppy diskettes and be able to store data on or retrieve data from such devices.
5.1 Describe the File System Structure

5.1.1 File Names in Linux

A file name can be up to 255 characters long. It may contain any number of special characters (‘ ’ or ‘%’, for example). Certain special characters (the dollar sign “$”, the semicolon “;”, or the space, for example) have a specific meaning. If you want to use one of these characters without the associated special meaning, the character must be preceded by a “\” (backslash) so its special meaning is masked (switched off). Umlauts, letters with diacritical marks, or other country-specific characters can be used. Using them, however, can lead to problems when exchanging data with people in other countries using other settings if these characters are not present on their keyboards.

Linux differentiates between uppercase and lowercase letters. For example, Invoice, invoice, and INVOICE identify three different files.

5.1.2 Basic Principles

The Linux file system is a hierarchical arrangement of directories and files. The basic structure is the same for all UNIX derivatives. Data is classified according to the following criteria:

- Static files (those that are not modified during operation, such as documentation) are distinct from dynamic files (those that can be changed, such as configuration files).

- Files are ordered according to their functionality, such as executable programs, configuration files, or help files.

- Operating system files are distinct from user files.

5.1.3 Structure

The hierarchically built file system starts with the root directory (root), which is denoted by the slash, “/”. The root directory contains a series of directories and subdirectories ordered according to the above-mentioned principles (see Figure 5.1 on the facing page). When referring to such a subdirectory, the slash (without a space) is placed in front of the directory (/home, for example). Further subdirectories are also separated from each other by a slash (/home/tux/).
5.1 Describe the File System Structure

A characteristic of the Linux file system is that the structure does not depend on the physical storage medium in which the directories are actually located. For example, if a computer is equipped with two hard drives, the /usr/ directory can be stored on one drive and all user data (the /home/ directory) can be stored on the other drive. Both directories are, however, directly attached to the file system in the root directory, so users do not even notice that the hard drive has changed when they change directories.

Figure 5.1: Structure of the File System
5.1.4 The Most Important Directories

The Home Directories

The /home/ Directory Because many people can work on a Linux system at the same time, the data of an individual user must be clearly separated from that of another user. To achieve this, each user is assigned a home area (/home/name)/. This directory can be organized according to personal requirements. This is where directories can be created, data stored, and personal programs installed.

The path for the user’s home directory can be abbreviated with the tilde (“~”). For example, for the user **tux**, ~/Documents/ corresponds to the path /home/tux/Documents/.

The /root/ Directory The system administrator (called root in Linux) also needs a home directory. This directory is called /root/.

Other Storage

The /media/ Directory /media/ contains a subdirectory for each replaceable medium (for example, floppy disk drives, CD-ROM drive, CD burner, USB stick). Here, the contents of such a data storage medium are mounted into the file system.

The /mnt/ Directory /mnt/ is the default directory for temporarily mounting file systems such as other partitions or for accessing directories exported over the network.

The /dataX/ Directories Depending on the hardware equipment and the configuration of the computer, the root directory may contain directories like /data1/, /data2/, /data3/, and so on. These directories allow access to other hard disks or partitions.

Temporary Files

The /tmp/ Directory In the /tmp/ directory, some programs create temporary files to store data. The content of this directory is regularly deleted, depending on the configuration, sometimes upon system start-up.

---

1 *name* is used here just as a place holder. The user’s subdirectory is usually marked with his login string (login name). For a user who logs in to the system with **tux**, the directory is called /home/tux/.
5.2 How to Use the Nautilus File Manager

5.2.1 Navigate through the File System

Nearly all work on the file system can be carried out with a GNOME program called Nautilus. To start Nautilus, double click on the following icons on the desktop:

- **Computer**: Nautilus shows the contents of the root directory.
- **username’s Home**: Nautilus shows the contents of the user’s home directory.

![Nautilus at the First Start-Up](image)

Figure 5.2: Nautilus at the First Start-Up

Double-click a directory icon in Nautilus to open a new Nautilus window showing the content of the selected directory.
5 Manage the Linux File System

The pull down menu in the left bottom corner allows you to switch to the parent directories of the active directory.

![Figure 5.3: Nautilus Showing the Parent Directories](image)

5.2.2 Owner and Access Permissions

Owner, Group and the Rest of the World

To separate the data of different users on a Linux multiuser system, users are assigned their own home directories in which to store personal data. This simple separation of data does not, in itself, effectively protect data against unwanted access from other users. *Owner and access permissions* are therefore assigned to stored data and executable programs.

To view the assigned permissions, right-click on a file or directory in Nautilus and select *Properties*. Select the *Permissions* tab.
To facilitate data access, users are divided into three categories:

- Each directory and each file is first uniquely assigned an *owner* (see Figure 5.4).

- In addition, each user belongs to one or more *groups* of users, who might, for example, be working on a project together and need access to the same data. For this reason, files are assigned not only to an owner, but also to a group (see Figure 5.4).

- All other users apart from this group are referred to as *others*. 

Figure 5.4: File Permissions
Regular Permissions

There are three possible permissions:

- Read (short form: r)
- Write (short form: w)
- Execute (short form: x)

Although they are similarly labeled in the permission dialog, the permissions for files and the permissions for directories are different. For files, the permissions mean:

Read  authorization to see the contents of the file – read access
Write  authorization to change the contents of the file – write access
Execute authorization to run the file as a program – execute access

For directories, the symbols mean:

Read  authorization to list the contents of the directory access
Write  authorization to create or delete files or access
Execute authorization to enter the directory

For each file you have to configure these three permissions for the file owner, the associated group and others.

To modify permissions for files or directories, just activate or deactivate the check boxes in the Permissions dialog.
5.2 How to Use the Nautilus File Manager

Special Permissions

The Permissions dialog lets you set special file permissions, which have the label Special flags. These permissions should be used with extreme care and are only explained here briefly.

<table>
<thead>
<tr>
<th>Name</th>
<th>Meaning for files</th>
<th>Meaning for directories</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set user ID</td>
<td>When the program is run, it runs with the permissions of the owner.</td>
<td>—</td>
</tr>
<tr>
<td>Set group ID</td>
<td>When the program is run, it runs with the permissions of the group assigned.</td>
<td>The files in the directory belong to the group for the directory and not to the group of the user.</td>
</tr>
<tr>
<td>Sticky</td>
<td>—</td>
<td>The user may only delete files if they belong to him or if he has explicit write permission.</td>
</tr>
</tbody>
</table>

5.2.3 Creating Directories

To create a new directory, click the white background of the Nautilus window. In the menu that appears, select Create Folder. A new directory icon appears, and you can enter the name of your new directory. Press Enter to finish the creation process.

Figure 5.5: Create a New Directory
Exercise: Create a Directory and Set Permissions

1. Start Nautilus by clicking the *tux's Home* icon on the desktop.
2. Enter the *Documents* directory by double clicking the icon with the left mouse button.
3. To create a new subdirectory, right-click anywhere on the white background of the Nautilus window.
4. Select *Create Folder*.
5. Enter *FirstFiles* as the directory name.
6. Press `Enter`.
7. Right-click the *FirstFiles* icon.
8. Select *Properties* from the popup menu.
9. Select the *Permissions* tab.
10. Deselect *Read* and *Execute* in the *Group* and *Others* lines.
11. Click *Close*.

5.2.4 Copying and Moving

The explanation below using files is also valid for directories. To copy a file, you must have read permission for the file and write permission for the target directory to which the file is being copied.

One way to copy a file is to drag and drop the file icon from one Nautilus window into another. If you hold `Ctrl` while moving the mouse pointer, the file is copied.

Another way is to use the popup menu. Right-click the icon of the file you want to copy and select *Copy File*. If you want to move the file, select *Cut File*. 
5.2 How to Use the Nautilus File Manager

Figure 5.6: Copy a File

Now you can navigate to the directory you want to copy the file to. Right-click the white window background and select **Paste Files** from the popup menu.

Figure 5.7: Paste a Copied File

To copy and move several files at the same time, hold down **Ctrl** while selecting files.
5 Manage the Linux File System

5.2.5 Renaming Directories and Files

To rename a file, right-click it, select the entry Rename... from the popup menu and enter the new file name.

You can also use the entry Properties for renaming files. At the Basic tab you can enter the new name.

Exercise: Copying and Renaming Files

1. Right-click myfile in the Documents window.
2. Select Copy File from the popup menu.
3. Double-click the FirstFiles directory.
4. Click with the right mouse button on the background of the new Nautilus window.
5. Select Paste Files.
6. Right-click the file myfile in the Documents window.
7. Select Rename... from the popup menu.
8. Enter myfile1 and press (→).
9. Repeat the last steps four times, but rename the copied files MyFile1, myfile2, myfile2a, and myfile3.
10. Repeat last steps one more time, but do not rename the copied file.

5.2.6 Deleting Directories and Files

You can delete files by throwing them into the trash can. Files thrown into the trash can be restored before the trash is emptied.

Right-click the file you want to remove. Select Move to Trash from the pop-up menu (see Figure 5.8 on the next page).
5.2 How to Use the Nautilus File Manager

You can move a file to the trash by dragging the file with the mouse over the trash can icon and then releasing the mouse button. The trash can icon on the desktop changes as soon as it contains something. To see what is in the trash can, double-click it. You can see the files that have been moved there or perhaps even retrieve one (keyword: moving).

A file that has been thrown in the trash has not really been deleted, so it still takes up hard drive space. To permanently remove or delete the items in the trash can, you must empty the trash can. To empty the trash can, right-click the trash can icon on the desktop. In the popup menu that opens, select Empty Trash (see Figure 5.9 on the following page).
5 Manage the Linux File System

Figure 5.9: Emptying the Trash

The second way to delete a file is to right-click it and then select Delete. The file is deleted completely and cannot be recovered.

**Exercise: Using the Trash Can**

1. Throw the file `myfile` from the `Documents` directory into the trash can.
2. Right-click the trash icon and select Empty Trash.
3. Confirm the dialog by clicking Empty.

5.2.7 Connecting Files: Links

Links are references to files or directories. Using links, you can access a file multiple times from different locations in the file structure without the file physically existing in each location. Links are thus a wonderful way of keeping order and avoiding redundancy.
5.2 How to Use the Nautilus File Manager

If you are working with a linked document, the original file is stored in only one directory, but a link to the document may be stored in other directories. The original file can now be opened in two ways: by opening the original file or by opening the link. The link is nothing more than a pointer to an original file, which is located somewhere else in the file system.

You can create a link by clicking the file icon and selecting Make Link from the popup menu. A new icon appears with the name link to file_name. Now you can move this icon where you want to.

By using drag and drop an icon is created, if you hold the right and Ctrl key pressed, while moving the mouse pointer.

Copying, moving, renaming, and deleting links works in the same way for both files and directories. You must be careful when deleting the original file. Remember to delete any links. If you delete a file without deleting any of its links and then click a link, an error message appears.
Exercise: Links

1. Right-click on the file icon myfile in the FirstFiles Nautilus window.
2. Select Make Link from the popup menu.
3. Right-click on the icon link to myfile.
4. Select Cut File from the popup menu.
5. Right-click on the background of the Nautilus window Documents.
6. Select Paste Files from the popup menu.
7. Right-click on the icon link to myfile.
8. Select Rename...
9. Enter myfile and press Enter.
10. Right-click on the file icon FirstFiles in the Documents Nautilus window.
11. Select Make Link from the popup menu.
12. Right-click on the icon link to FirstFiles.
13. Select Cut File from the popup menu.
14. Right-click on the background of the desktop.
15. Select Paste Files from the popup menu.
16. Right-click on the icon link to FirstFiles.
17. Select Rename....
18. Enter FirstFiles and press Enter.
19. Close all Nautilus windows.

5.3 How to Search for Files

Sometimes you need to find a file, but you do not know exactly where it is in the file system. You might know the name of this file or only a part of the name. You might need a list of all files that have been modified in the last two days or that exceed a certain size.
5.3 How to Search for Files

To find files with specific features select the System menu with Search for Files....

![Image of the Search Utility window]

Figure 5.11: The Search Utility

In the Name contains field, enter the name of the file you want to find. If the name of the file is not completely known, you can use the two wildcards “?” (for any character) and “*” (for none, one, or several characters).²

**Example:** Suppose the following files exist:

- File
- file
- File1
- File1a
- File1b
- File2
- File2a
- MyFile

²You do not need to enter an asterisk before or after the search item.
The following table shows the results of three different search strings:

<table>
<thead>
<tr>
<th>Search string</th>
<th>File?</th>
<th>File*</th>
<th>?ile*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Found Files</td>
<td>File1</td>
<td>File</td>
<td>File</td>
</tr>
<tr>
<td></td>
<td>File2</td>
<td>File1</td>
<td>file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>File1a</td>
<td>File1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>File1b</td>
<td>File1a</td>
</tr>
<tr>
<td></td>
<td>File2</td>
<td>File1b</td>
<td>File2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>File2a</td>
<td>File2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>File2a</td>
</tr>
</tbody>
</table>

Table 5.1: Search Strings and Results

Enter the directory you want to search in Look in folder. You can also use the button Browse to specify the directory you want to search in.

Click Find to start the search process. All matching files and directories are shown in the lower window with details of their locations (see Figure 5.12).

Figure 5.12: Successful Search

Further settings can be made when you open the menu under Show more options. Select a search rule from the pulldown menu Available options. After clicking the Add button, a
new text field is added and you can enter the information the chosen option needs. To remove a search rule click the Remove button next to the rule.

**Exercise: Searching for Files**

1. Start the GNOME search tool by selecting **System → Search for Files**....
2. To find all files with `file` inside the file name, enter `file` into the text field **Name contains**.
3. Click the **Find** button.
4. Double-click the **FirstFiles** directory in the search results.
5. Quit the search tool by pressing the **Close** button.
6. Close the Nautilus window.

### 5.4 How to Access Removable Media

#### 5.4.1 Floppy Disks, CDs, and DVDs

As described in section 5.1.4 on page 56, external media like floppy disks, CDs, and DVDs are mounted in the `/media` directory. To access the files on them, you must have rights to the directory. The available devices are accessed through directories, such as:

- `/media/cdrom/`
- `/media/cdrecorder/`
- `/media/dvd/`
- `/media/floppy/`

When you click the icon at the desktop, Nautilus shows you the data content of the medium.
5.4.2 USB Sticks

USB devices (such as USB memory sticks) are mounted in the /media/ directory. The name is /media/usb-number, where number is a unique hardware identifier.

One difference exists between USB sticks and the other external devices described in the previous section: A few seconds after you plug a USB stick into the USB port, a window pops up and asks you what to do.

If you select Yes, Nautilus will start automatically and show you the content of the USB stick. If you select No, Nautilus does not start. You can open it manually and see the content of the USB stick by navigating with Nautilus to the /media/usb-number directory.

If you want to see this dialog every time you plug in a USB stick, then you need to deactivate the checkbox Do not ask again.

Exercise: Copy Exercise Files to Your Home Directory

1. Insert a floppy disk with some Microsoft Word and Excel documents into your floppy disk drive.
2. Double click the floppy icon on the desktop to start Nautilus.
3. Select all your Word and Excel documents with the mouse; then right-click on an icon.
4. Select Copy File from the popup menu.
5. Double click the tux’s Home icon on the desktop.
6. Double-click the Documents directory icon.
7. Right-click the background of the Documents window.
8. Select Paste Files from the popup menu.
9. Close all Nautilus windows.

5.5 How to Format a Floppy Diskette

There is a GNOME application that allows you to format a floppy disk in the Programs menu at System Tools → Format a Floppy.

Contemporary floppy disks are 3.5”. Very old computers can still feature drives for 5.25” floppy disks. These floppy disks were larger than the currently used disks and had a capacity of 360 KB to 1.2 MB. The first generation of the currently used 3.5” floppy disks had a capacity (at “double density”) of 720 KB. Contemporary “high-density” 3.5” floppy disks have a capacity of 1.44 MB. Choose your kind of floppy from the pulldown menu Floppy density.

You can choose two kinds of file system types from the pull-down menu File system type:

- DOS (FAT): These floppy disks can also be accessed by systems running Microsoft Windows.
- Linux Native (ext2): The standard format for Linux. It allows you to manage access permissions for the saved files.

In the text box Volume name you can enter a name for the floppy you want to format.

There are three modes of formatting:

**Quick** Deletes only the directory entries on the floppy disk. The actual files are not erased by this option.

**Standard** Reallocates the tracks and sectors on the floppy disk and overwrites existing files. You should use this option to format a used floppy disk when you are deleting confidential files. Otherwise, special tools could be used to recreate the data.

**Thorough** Checks the floppy for bad blocks while formatting.
5 Manage the Linux File System

Figure 5.14: The Tool for Formatting Floppy Disks

**Exercise: Format a Floppy Diskette**

1. Insert a floppy disk into your floppy disk drive.
2. Start the floppy utility from the Programs menu at System Tools → Format a Floppy.
3. Click Format. This will format the floppy disk in the DOS format.

**Summary**

- You can store files in the Linux file system and change access permissions to your files and directories.
- You can work with the files and directories you created and create links for your convenience.
5.5 How to Format a Floppy Diskette

- You can work with removable devices such as CD-ROM, floppy disks, and USB sticks to store and receive data from such devices.

- You can work confidently with floppy disks, which are still the easiest way to share small amounts of data between computers and users.
5  Manage the Linux File System
6 Work with the Installed Office Suite
OpenOffice.org

Objectives

After you complete this chapter, you should be able to do the following:

- Understand the OpenOffice.org suite and its components and perform the basic OpenOffice configuration.
- Establish compatibility with Microsoft Office in the OpenOffice suite so you can use MS Office-created documents in OpenOffice.
- Describe the configuration and help system of OpenOffice and use this Office suite on your Linux system.
6 Work with the Installed Office Suite OpenOffice.org

6.1 A Brief History of OpenOffice.org

OpenOffice was developed from the StarOffice product whose source code was made freely available by Sun Microsystems, Inc. In turn, newer versions of StarOffice are based on OpenOffice.org. Therefore, the look and feel of OpenOffice.org and StarOffice are almost identical.

6.2 Starting the OpenOffice.org Components

OpenOffice.org is included in the Novell Linux Desktop. Click the icon in the top panel to start the word processor component of OpenOffice.org.

![Figure 6.1: The Icon for the Word Processor in OpenOffice.org](image)

You can start an additional OpenOffice.org component anytime from an already opened OpenOffice.org module by selecting File → New.

For example, you can start a new spreadsheet from the running word processor by selecting New → Spreadsheet from the File menu.

To start the individual components of the Office package from the submenu Office of the Programs menu, select:

<table>
<thead>
<tr>
<th>Menu Entry</th>
<th>Name of the Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word Processor</td>
<td>OpenOffice Writer</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>OpenOffice Calc</td>
</tr>
<tr>
<td>Presentation</td>
<td>OpenOffice Impress</td>
</tr>
<tr>
<td>Drawing</td>
<td>OpenOffice Draw</td>
</tr>
</tbody>
</table>

Table 6.1: OpenOffice.org Components
6.3 How to Establish Compatibility with Microsoft Office

Users experienced with other office suites, especially the Microsoft Office suite, should be able to easily work with OpenOffice.org. OpenOffice.org is able to open files stored in standard Microsoft Office formats. Just select the file from the \texttt{File \rightarrow Open} dialog.
Files created with OpenOffice.org can also be stored in standard Microsoft Office formats. For example, select **Save as...** from the **File** menu, then enter `.doc` as the file extension. For other file formats you can open the menu **Browse for other folders** in the lower right corner of the file selection dialog. Select the **Microsoft Word 97/2000/XP** file format for Microsoft Word. **Microsoft Excel 97/2000/XP** is offered for OpenOffice.org Calc spreadsheets. **Microsoft PowerPoint 97/2000/XP** is offered for OpenOffice.org Impress presentations.
6.3 How to Establish Compatibility with Microsoft Office

Different office suites are built for different target user groups, so the handling and functionality details are different. Thus, if you have a Microsoft Word document that uses a lot of Microsoft Word-specific features, such extended features may not be well translated into OpenOffice Writer. The same is true for other office components and, of course, works in both directions.

Later in this chapter, you will use your own Microsoft Office documents in an exercise to see how well they are imported into OpenOffice.org.
6 Work with the Installed Office Suite OpenOffice.org

Note! With OpenOffice.org, you can create a PDF file directly. In every component, you can select File → Export as PDF.... You can also select a standard icon on the menu bar to export the current documents directly as PDF. This is a very convenient way to share data with others using an application-independent format. PDF readers are available free of charge on virtually any computer system. Your Novell Linux Desktop has the PDF interpreter installed by default; it is the Acrobat Reader, which is also popular on Microsoft Windows systems.

6.4 How the OpenOffice.org Components Work Together

It is as easy to combine the different parts of OpenOffice.org as it is to work with other, commercial office suites. If you want to insert a table into a text document, you can mark the cells, select Copy from the Edit menu, switch to the text document and select Edit → Paste. This method works for all OpenOffice.org components and a lot of non-OpenOffice.org programs (e.g., the Firefox web browser and the Evolution mail client).

From the other non-OpenOffice.org programs, you can not copy directly. You have to save the information first in a file and then open or import the file using options on the Insert menu.

By pressing the Prnt Scrn key on your keyboard a screenshot is made and a dialog for saving the screenshot starts automatically. Save the screenshot into a file. You can insert it into an OpenOffice document by selecting Insert → Graphics....

6.5 How to Configure OpenOffice.org

You can configure OpenOffice.org for your individual needs. The configuration dialog can be opened with Tools → Options....
6.6 How to get Help for OpenOffice.org

You can customize your OpenOffice.org application using the same options provided by other full-featured office applications such as Microsoft Office. This kit cannot guide you through all of these options. However, you have most likely customized your Microsoft Office product. Based on that knowledge, you should be able to customize OpenOffice.org to meet your needs and preferences.

6.6 How to get Help for OpenOffice.org

6.6.1 Help Agent

OpenOffice.org features a context-sensitive help function. Certain actions activate the Help Agent in the lower right corner of the application. You can also double-click the image of a light bulb to start the help system.
6.6.2 Online Help

You can request information about a certain topic manually from the help system with Help → Contents. The help text is displayed in the right-hand frame. The help pages are cross-referenced with links, just like web pages. The left-hand frame offers four tabs for finding information about the topic of interest:

**Contents** This tab features a table of contents with all the chapters available for help.

**Index** This tab features keywords like an index of a book. A search function helps you find a keyword.

**Find** This tab lets you search the contents of all help chapters for specified terms.

**Bookmarks** Use the icon to the far right to mark interesting help pages with a bookmark. The tab **Bookmarks** lists all previously set bookmarks.
6.6 How to get Help for OpenOffice.org

![OpenOffice.org Help](image)

Figure 6.7: OpenOffice.org Help

**Exercise: Using OpenOffice.org**

1. Start OpenOffice.org by clicking the OpenOffice icon in the top panel.
2. The OpenOffice Writer starts up.
3. Write a short text using OpenOffice Writer.
4. Select File → Save As....
5. Select the directory Documents in the menu Save in folder.
6. To save your text in the Microsoft Word format, enter the file name FirstDoc.doc in the textbox File name.
7. Still in the word processor, use File → Open to open the Microsoft Word document you saved earlier.


9. In OpenOffice use the File → Open dialog to open the Microsoft Office spreadsheet you copied earlier to your file system.

10. Check out your spreadsheet and its functionality in OpenOffice Calc.

11. Close all OpenOffice.org applications.

Summary

- You have customized OpenOffice.org on your Linux system for your convenience.
- You have created a simple OpenOffice.org document and stored it on your file system.
- You verified that your Microsoft Office documents can be opened in OpenOffice.
7 Optimize Office Communication and Collaboration

Objectives

After you complete this chapter, you should be able to do the following:

- Describe the Novell Linux Desktop modules for office communication and collaboration.
- Customize Evolution and Gaim on your Linux system to fit your personal needs.
7 Optimize Office Communication and Collaboration

7.1 Handling E-mail with Evolution

7.1.1 Configuring Evolution

You can start Evolution by clicking the Evolution icon (see Figure 7.1) in the top panel or by selecting Internet → E-Mail in the Programs menu.

![Figure 7.1: The Icon for Starting Evolution](image)

The first time you start Evolution, a wizard runs to help you configure the program.

![Figure 7.2: The Configuration of Evolution Starts](image)
Click **Forward** to begin with the configuration.

In the next screen, you configure your identity.

![Figure 7.3: Enter Your E-mail Address](image)

First, enter your full name and your mail address (see Figure 7.3). Optionally you can enter the name of your organization and another mail address where replied mails are delivered. Click **Forward** to go ahead.
Next, you need to enter the name of the server for incoming mail.

You need to apply the Internet Mail settings from your network administrator or your Internet Service Provider.

Choose the appropriate settings for your account from the **Server Type** pulldown menu:

- **None** Choose this if you do not want to receive mail.
- **IMAP** Choose this if you want to access an IMAP mail server.
- **POP** Choose this if you want to access a POP mail server.
- **USENET news** Choose this if you want to use Evolution as a news reader.
7.1 Handling E-mail with Evolution

**Local delivery** Choose this if your workstation is working as a mail server or it is not connected to a network.

**MH-format mail directories** Choose this if your e-mail messages are already delivered to spool using the MH format.

**Maildir-format mail directories** Choose this if your e-mail messages are already delivered to a mounted mail directory.

**Standard Unix mbox spool or directory** Choose this if your e-mail messages are already delivered to spool using the mbox format.

The Configuration part of the dialog may need more information. You might have to specify the host of your mails, your user name on that host and a password. You may have to select a mail directory, where new mails can be stored. You can get these settings from your network administrator or your Internet Service Provider.

In most cases you have to choose between IMAP and POP. Click Forward to go ahead.
The next dialog will vary slightly, depending on your server type for receiving mail.

![Figure 7.5: Specify How Often to Check the Mailbox](image)

In most cases you have to specify how often your mailbox is checked for new mail.

Click **Forward** to go to the next dialog.
7.1 Handling E-mail with Evolution

Now you have to configure how to send mail. Choose which type of transport you want to use:

**SMTP** You can configure the details of your mail servers manually.

**Sendmail** You can apply the settings if your workstation works already as a mail server. Choose this if your workstation is not connected to a network.

![Figure 7.6: Configure the Server for Outgoing Mail](image)

In most cases you will select SMTP here, based on the settings from your network administrator or Internet Service Provider.
7 Optimize Office Communication and Collaboration

You can enter the settings of your server for sending e-mail. You have to

- Enter the real name of the server Host
- Specify if the server requires authentication:
  - The type of authentication (Type)
  - Your login name (Username)

Click Forward to go to the next dialog.

You can enter a name for your configuration. This is useful, if you have to manage multiple mail configurations (e.g. one for private mail and one for business mail).

![Account Management](image)

Figure 7.7: Name the Configuration

Click Forward to go to the last configuration dialog.
You finally have to specify the timezone you are living in.

![Figure 7.8: Select Your Timezone](image)

You can select it by clicking the map or by choosing from the Selection menu.

After clicking Forward you should get a confirmation that the configuration was successful. Now you can start Evolution by clicking the Apply button.
7 Optimize Office Communication and Collaboration

7.1.2 Reading Mail

After starting Evolution, the mail client user interface of Evolution appears.

You can see the list of available mail folders in the left window area. If you select one folder, the content is shown in the right upper area. All mail inside this folder are listed and you can see the sender of the mail, the subject and the date.

The three icons at the beginning of each mail entry indicate:

- If the envelope is closed, the mail is new and unread.
- The second icon shows whether the mail includes an attachment.
- The exclamation mark indicates important mail.

Select a mail in the list of mails and it is shown in the lower area.
7.1 Handling E-mail with Evolution

7.1.3 Composing and Sending New E-mail

If the configuration of Evolution is done, you can start writing messages. To write a new message, click the (New) icon in the Evolution toolbar. A new window appears, (see Figure 7.10). Enter the recipient’s address, the subject, and the message body. Click Send to send the message.

Note! You can write e-mail messages to an user of your local machine by using the mail address login@localhost. You do not need a connection to any network.

Note! There are some formatting buttons visible, but not activated. This is because mail is created in plain text by default. You can use the formatting options only if you send mail in HTML. This option can be activated at Format → HTML.
7.4 Repeating to a Message

If you want to reply to a message, select the message in the list of mail and click the Reply button. The original message is opened as quoted text for editing. The sender of the original message is automatically set as the recipient. The subject of the original address is also copied.

You can also select Reply to All if the original mail was sent to more than one addressees and you want to send your answer to every one of them.

7.5 Attachments

You can also send a file attached to the e-mail message. To do this, click the Attach button in the toolbar of the window for composing the message (see Figure 7.10 on the preceding page). In the dialog that opens, navigate through the directory tree and select the file you want to attach to the e-mail message. Then click Open.

An attachment to a received email is marked with an icon at the bottom of the message body. When you click the icon, Evolution tries to show the content of the attachment. If you select the triangle button, a popup menu appears asking whether the attachment should be opened with a specific application or saved as a file.

Exercise: Using Evolution

In this exercise you will configure and write your first mail with Evolution. This exercise assumes that you have gathered the needed information from your network administrator or your Internet Service Provider.

If your computer is connected to a network, complete the following:

1. Launch the Evolution application from the Programs menu by selecting Internet → E-Mail.
2. Confirm the welcome screen of the configuration wizard by clicking Forward.
3. Type your email address in the Email Address textbox and click Forward.
4. Select your account type.
5. Insert the access data for your mail server and click Forward.
6. Click Forward in the next dialog.
7. Choose SMTP in the next window and click the Forward button.
8. Insert the access data for your mail server and click Forward.
9. Click Forward.
10. Select your timezone from the Selection pulldown menu and click Forward.
11. Click Apply.
12. To write a new message, click the New button in the Evolution toolbar.
13. Enter the addressee in the To text field.
14. Enter the subject of your mail into the Subject field (e.g. My first mail with Linux).
15. Enter the message.
16. Click the Send button.
17. To send all written mail, click Send/Receive.

If your computer is not networked, complete the following:

1. Launch the Evolution application from the Programs menu by selecting Internet → E-Mail.
2. Confirm the welcome screen of the configuration wizard by clicking Forward.
3. Enter the address tux@digitalairlines.com in the Email Address field and click Forward.
4. Select Local delivery as your server type and click Forward.
5. Just click Forward in the next dialog.
6. Choose Sendmail in the next window and click the Forward button.
7. Click Forward.
8. Select your timezone from the Selection pulldown menu and click Forward.
9. Click Apply.
10. To write a new message, click the New button in the Evolution toolbar.
11. Because you are not connected to a network, enter tux@localhost into the To field.
12. Enter the subject of your mail in the Subject field (e.g. My first mail with Linux).
13. Enter the message.
14. Click Send.
15. To check for new mail, click Send/Receive.
16. Select the Inbox mail folder and select the new mail to read it.

7.2 Managing Contacts

Click **Contacts** in the left bottom corner to open the Evolution addressbook. If you do not have an Evolution window open, select **Accessories → Calendar** from the **Programs** menu.

Figure 7.11: The Address Book for Managing E-mail Addresses
You can add a new entry to the address book directly from the mail client by right-clicking a highlighted e-mail address in a message header and then choosing Add to Addressbook from the pop-up menu.

Create a new address entry by clicking the New icon on the icon bar or by choosing File → New → Contact.

The most important information can be entered on the Contact tab. The tabs Personal Information and Mailing Address allow you to specify additional data.

To add an address from the address book into the addressee text field of the message composition window, click To. A new dialog opens and you can choose the contacts.

To search for a contact, you can use the Name begins with pulldown menu.
Exercise: Using the Address Book

1. Start the contact component of Evolution by clicking Contacts in the left lower corner of the Evolution window.
2. Add a new contact by clicking the New icon at the icon bar.
3. Click Full Name.
4. Enter your name, select a title and click OK.
5. Enter your mail addresses into the area Email.
6. Click OK.
7. Double click the new entry in the right window area.
8. Enter your telephone numbers into the area Telephone.
9. Click OK.
10. Click the new contact you just created and send an e-mail directly.

7.3 Managing Appointments

Evolution ships with its own scheduler. You can start it by clicking Calendars in the lower left corner of Evolution or directly from the Programs menu with Accessories → Calendar.

The calendar main window is divided into three frames (see Figure 7.13 on the next page). A small overview of the current month is displayed in the upper right frame. The day marked red is the actual date. The day(s) marked with a grey background are displayed in the large main frame in the middle. The frame to the right and below the calendar is reserved for unfinished tasks.
7.3 Managing Appointments

There are various different visualization options for the personal schedule: by days, by work weeks, by weeks, by months and as a simple listing. Using the mouse, select days in the monthly calendar. These will be displayed in the main frame.

Use the New button or double-click the main frame of the calendar to open a window ready for input about an event. The window has fields for beginning, end, description, and other details regarding the scheduled event. By default, the time on which the mouse was clicked is used as the beginning time for the scheduled event.

In the Date and Time section you find the Alarm option if you want an alert for this appointment.

In the Recurrence tab you can specify the repetition of this appointment.
Exercise: Managing Appointments

1. Start the calendar by clicking Calendar in the lower left corner of the Evolution window.
2. Select tomorrow’s date in the timetable.
3. Enter a new appointment by double-clicking the timetable.
4. Double click the grey box next to 10am.
5. Enter a title for the appointment in the Summary field.
6. Adjust the value for end time to 12:00 PM.
7. Click OK.
7.4 Managing Tasks

Evolution also helps organize to-do lists. To open the to-do list, click Tasks. You can also start the task module directly from the Programs menu with Accessories → Task List.

Enter new tasks by clicking Click to add a task in the task list or by clicking the New button. A dialog for creating a new task appears.

★ Note! If you have created a task, but it is not shown in the task list, make sure that the task group (e.g., Personal) is activated in the text area at the left edge.
Exercise: Managing Tasks

1. Start the task list by clicking on the Tasks button in the lower left corner of the Evolution window.
2. Make sure the Personal task group is activated in the left field.
3. Enter a new appointment by clicking New.
4. Enter a title for the task in the Summary field.
5. Click OK.

7.5 Instant Messaging with Gaim

7.5.1 Configure Gaim

Instant messaging can be used for private chatting, but it can be very useful in company communications, too. Instant messaging is much faster than e-mail. Novell Linux Desktop includes an instant messenger application called Gaim.

To start Gaim select Internet → Instant Messenger from the Programs menu.

After the first login you have to configure an account. Click Add in the Accounts window (see Figure 7.16 on the facing page).
7.5 Instant Messaging with Gaim

Gaim supports the following protocols:

- AIM
- ICQ
- Gadu-Gadu
- GroupWise
- IRC
- Jabber
- MSN
- Napster
- Yahoo
- Zephyr
The dialog differs slightly for the different instant messaging protocols. But you always have to enter the following information:

- Your login name (Screen Name)
- Your password
- The alias for your login name (Alias)
- Whether you want Gaim to remember your password (Remember Password)
- Whether you want Gaim to log in automatically after its start (Auto-login)

You may have to enter additional information, depending on the chosen protocol.
7.5 Instant Messaging with Gaim

7.5.2 Using Gaim

After configuring your account, you can select it in the login mask of Gaim (menu Account). You also have to enter your password.

![Login Dialog of Gaim](image)

Figure 7.18: The Login Dialog of Gaim

After clicking the **Sign on** button, the list of users on your buddy list appears.

⚠ **Note!** By default only the online buddies are shown. If you want to see your offline buddies, select **Buddies → Show Offline Buddies.**
Figure 7.19: The List of Buddies

Double-click a list entry to open the chat dialog. Alternatively you can select an entry in the buddy list and click IM.
7.5 Instant Messaging with Gaim

Once started you can minimize the Gaim window. Gaim continues to listen for incoming chat invitations. A Gaim icon is shown in the panel notification area.

If you want to quit Gaim completely, right-click the icon in the panel notification area and select Quit from the popup menu.
Summary

- You can use the Linux collaboration tools, such as e-mail, contacts, appointments, tasks, and notes, with your standard network services or with your Internet Services Provider.
- You can access all collaboration tools of Evolution.
- You are able to configure and use the instant messenger Gaim.
8 Manage Graphics

Objectives

After you complete this chapter, you should be able to do the following:

- Create a screenshot from your Linux desktop and import it into an OpenOffice Writer document.
- Create a vector graphic using OpenOffice Draw, save it to a file, and import that file into an OpenOffice Writer document.
- Manipulate a pixel graphic with Gimp, save the graphic to a file, and import that file into an OpenOffice Writer document.
8 Manage Graphics

8.1 Create a Screenshot to Be Used with OpenOffice Writer

8.1.1 Create a Screenshot

You can quickly create a screenshot by using the $\text{Print Scrn}$ key on your keyboard. A dialog opens that lets you enter a path and file name in the Save screenshot to file field. All screenshots are saved as PNG files. After clicking Save, you need to launch a pixel graphic program such as Gimp or even OpenOffice.org.

![Dialog for Saving a Screenshot](image)

**Note!** $\text{(Alt+Print Scrn)}$ takes a screenshot of the window to which the mouse points.
8.1 Create a Screenshot to Be Used with OpenOffice Writer

The option Save screenshot to desktop creates a new icon on your desktop. Save screenshot to web page saves the screenshot in the directory ~/public_html/.

You can insert a graphic file into a OpenOffice.org component by selecting Insert → Graphics... → From File.... Navigate to the saved graphic file, select it with the mouse and click Open.

Exercise: Taking a Screenshot

1. Click the Print Scrn key on your keyboard.
2. Click Browse....
3. Enter MyScreenshot.png into the text box Name.
4. Open the pull-down menu Browse for other folders.
5. Select the Documents directory inside the home directory.
6. Click the Save button.
7. Click the Save button.
8. Launch OpenOffice Writer from the KDE menu by selecting Office → Word Processor → OpenOffice.org Writer.
9. Type “This is my first imported screenshot” and press Enter to get a new line.
10. Select Insert → Graphics → From File.
11. Navigate to your Documents directory (/home/tux/Documents) and select the MyScreenshot.png file.
12. Click Open to import the file with an anchor at the current cursor position.
13. Save your document in your Documents directory with the name Screenshot-exercise.sxw.
8 Manage Graphics

8.2 Create a Drawing with OpenOffice Draw and Use It in OpenOffice Writer

8.2.1 Create a Drawing

You can launch OpenOffice.org Draw from the Programs menu using Office → Drawing or from any running OpenOffice.org application using File → New → Drawing.

![Figure 8.2: The OpenOffice.org Draw Main Window](image)

You can see the main tool bar for OpenOffice.org Draw on the left side of the window. Most of the icons in the tool bar display a small blue arrow. The arrow indicates that more tools are available. To select a hidden tool, click the blue arrow and leave your mouse button pressed for one second.
8.2 Create a Drawing with OpenOffice Draw and Use It in OpenOffice Writer

★ Note! The “Connector” tool is a useful feature for charts. You can find it in the main tool bar. You can use the Connector to link two objects with a line. If you move one of the objects, the connection line moves as well.

Figure 8.3: The Connector Tool

✎ Exercise: Using OpenOffice.org Draw
In this exercise you will create a new vector graphic with OpenOffice.org Draw and copy and paste content between OpenOffice.org applications.

1. Start OpenOffice.org by clicking the icon on the desktop.
2. Select File → New → Drawing.
3. Select the Rectangle tool and draw a small rectangle.
4. Select the Ellipse tool and draw a small ellipse.
5. Select the Connector tool and draw a connection line between the rectangle and the ellipse.
6. Select and move the rectangle around and watch the connector lines following your movement.
7. Using File → Save As..., save the image as a Draw file.
8. Make sure the file will be saved inside the Documents directory.
9. Enter MyFirstImage in the Name text field.
8  Manage Graphics

10. Click Save.
11. Copy your image to a text document by selecting all objects with Edit → Select All.
12. Copy the marked objects to the clipboard by selecting Edit → Copy.
14. Type “This is my first OpenOffice drawing” and press Enter to get a new line.
15. Insert the contents of the clipboard into the text document by selecting Edit → Paste.
16. Save the text document in OpenOffice format by selecting File → Save As....
17. Make sure the file will be saved inside the Documents directory.
18. Enter TextWithImage into the Name text field.
19. Click Save.

8.3  Processing Pixel Images with Gimp and Using Them in OpenOffice Writer

8.3.1  Basics

You can use Gimp, a free graphics application, to process scanned photos or images from the Internet. “Gimp” is an acronym for “GNU Image Manipulation Program.” The application is very powerful, but it requires some practice to use effectively. You can start Gimp from the KDE menu → Graphics → Gimp Image Editor.

At the first start, you have to configure Gimp. But the default values supplied are sufficient for most users; so you can move through the configuration wizard by clicking Continue.

The main window in Gimp is named The Gimp (see Figure 8.4 on the next page). This window contains drawing tools, selection tools, retouching options, and a selection of colors, patterns, and brushes. Gimp also offers a variety of impressive effects. It is out of the scope of this kit to introduce all features of Gimp. However, the few examples given below will give you a quick introduction to discover Gimp. If you work with a lot of pixel graphics, you should take a closer look at Gimp.
8.3 Processing Pixel Images with Gimp and Using Them in OpenOffice Writer

Figure 8.4: The Gimp Main Window
8.3.2 Opening and Saving

To open a file in Gimp, you must first choose Open... from the File menu. This opens a dialog from which you can select the file you want to open. The loaded image is displayed in a new window. Most functions of Gimp can be accessed by the menu bar on the top of every image window. To save the image, you select File → Save as.... This menu is available by right-clicking the image.

★ Note! You can create a screenshot directly in Gimp via File → Acquire → Screen Shot....

You can insert a graphic file into an OpenOffice.org component by selecting Insert → Graphics... → From File.... Navigate to the saved graphic file, select it with the mouse and click Open.

8.3.3 Color Correction

Sometimes the colors of an image are not ideal. A picture might be discolored by flash overexposure or might have received an odd tint during the scanning process. In other cases, bad lighting might have led to underexposure. Gimp offers various options for postprocessing color correction. You can access the color correction options by selecting Layer → Colors in the Image menu.

You can use Brightness-Contrast... to darken bright images (Brightness) and brighten dark images. You can make colors appear stronger by raising the value with Contrast. Figure 8.5 on the facing page illustrates the difference between the original color in the upper left half of the image and the slightly darkened lower right half.

The Layer → Colors → Auto option offers you five proven color enhancement procedures to try. These procedures lead to variable results, depending on the source image, but trying these automatic procedures may be worthwhile. If the changes are not acceptable, you can undo them by right-clicking the image and then selecting Edit → Undo or, alternatively, using the keyboard shortcut (Ctrl)Z.
8.3 Processing Pixel Images with Gimp and Using Them in OpenOffice Writer

8.3.4 Masking Areas

Sometimes you might not want to modify the whole image, only part of it. This may be the case, for instance, with the “red eye” effect. You can use any of the six selection tools in the main toolbox in selecting an area for touchup (the technical term for this procedure is masking).

Because you need to create as accurate a mask as possible, you should first zoom in on the area you want to select using the magnifying glass tool (the third symbol from the right in the second row from the top). (See Figure 8.4 on page 119.)

The selection tools allow you to do the following:

**Rectangular selection**  Select a rectangular area.

**Elliptic selection**  Select a round or an elliptical area.

**Freehand selection**  Select an arbitrary area with the cursor.
Automatic fuzzy selection  Click a low-contrast area to select it automatically. This tool is commonly known as the magic wand. The scope of the magic wand can be adjusted by keeping the mouse button pressed down and moving the cursor.

Selection by color  Select an area with similar colors.

Intelligent scissors  This tool represents a combination of the magic wand and the path selection tool. Gimp tries to connect a number of given points automatically, based on the features of the image. The more points given, the more accurate the selection will be. Complete the selection by clicking inside the bounded area.

Bezier curve (path) selection tool  Select an area by defining a path around it. You can round the corners of the selection by moving the cursor while holding down the mouse button. Complete the selection by clicking the initial point inside the marked area. To convert the path into a selection, choose Select → From Path in the image menu.

You can use the Layer → Colors → Hue-Saturation... option (found in the Image menu) to correct “red eye.” When only the iris of the subject is selected, the changes affect only the selected area, not the entire image.

Figure 8.6: Color Correction on Eyes
8.3 Processing Pixel Images with Gimp and Using Them in OpenOffice Writer

8.3.5 Special Effects

Gimp provides several special-effects tools. Filters offers a number of submenus that contain various special-effect functions.

Not all effects can be applied to all image modes. Some effects require a selection; some do not. Some only make sense when applied to a color image, some only when applied to monochrome images. Many filters require a lot of processing power, so you may have to wait for the results to be displayed on slower computers.

Figure 8.7: The Effect of the Artistic → Cubism... Filter
Exercise: Using Gimp

This exercise will guide you through a few Gimp features.

1. Copy the /opt/gnome/share/pixmaps/backgrounds/Novell/RedLeaves.jpeg file into your home directory (“~”).
2. Launch Gimp by selecting Programs → Graphics → Gimp Image Editor.
3. Before you can use Gimp, you need to configure it first. Click Continue five times.
4. Close the Welcome dialog by clicking Close.
5. Close the Layers, Channels, Paths... window by clicking the “X” button.
6. Open the image you have stored in your home directory by selecting File → Open.
7. Select the file name with your mouse and click OK.
8. Select the rectangular selection tool (on the left side of the first line) in the main window.
10. From the Image menu, select Layer → Colors → Colorize.
11. Change the Hue value to 320, the Saturation value to 90, and the Lightness value to 25.
12. Click OK.
13. Delete the selection by choosing Select → None in the Image menu.
14. From the Image menu, select Filters → Artistic → Cubism....
15. Leave the default values untouched and click OK.
16. Save your image in your home directory by selecting File → Save as....
17. Enter the filename cubism.png in the text field at the bottom of the Save dialog and click OK.
18. Leave the default values in the next window untouched and click OK.
8.4 Draw Diagrams with Dia and Using Them in OpenOffice Writer

19. Exit Gimp by selecting File → Quit in the menu of the main window.
20. Open a new OpenOffice Writer document and insert the pixel graphic you stored into that document.

8.4 Draw Diagrams with Dia and Using Them in OpenOffice Writer

8.4.1 Basics

Drawing diagrams is very important in an office environment. Of course it is possible to draw diagrams in OpenOffice.org Draw. Especially because of the connector tool (see Figure 8.3 on page 117), OpenOffice.org is a good choice.

Figure 8.8: The Diagram Editor
But if you have to draw a diagram in a common syntax (e.g., network diagrams and flow charts), it is better to use a tool that is already designed to use this “diagram language.” You can use the tool Dia, which is included in the Novell Linux Desktop.

You can start Dia by selecting Programs → Graphics → Diagram Editor.

### 8.4.2 Create a Diagram

To create a new diagram, select File → New.

In the upper toolbox you can find some general tools like boxes, cycles and lines. In the pulldown menu, which is labeled Assorted after the start of Dia, you can find a selection of many “diagram languages.”

The items of the selected language are shown in the area under this pulldown menu. You can select an item with your mouse. To insert it into the diagram, just click the diagram window. If the item demands a label, the cursor is directly set to the correct position and you can start typing.

The lines shown in the upper toolbox can be used as connectors. At the edges of every object you can find small crosses. Just move the start or the end of a line onto a cross and Dia will connect the objects automatically. The color of the connected points switches to red.

### 8.4.3 Save and Import into OpenOffice

Like Gimp, there is an popup menu available by right clicking the diagram. There you can find the File menu, which includes Save as and Export options.

Because OpenOffice.org can not import native Dia files, you should to select Export and select the PNG format.

You can insert a graphic file into an OpenOffice.org component by selecting Insert → Graphics... → From File.... Navigate to the saved graphic file, select it with the mouse and click Open.
Exercise: Using Dia
This exercise will guide you through a few Dia features.

1. Start Dia by selecting Programs → Graphics → Diagram Editor.
2. Create a new diagram by selecting File → New.
3. Click on the Ellipse tool (second line, second row) to select it.
4. Click inside the diagram window to insert the ellipse.
5. Enlarge the ellipse by dragging the green dots.
6. Select Misc from the Assorted pulldown menu.
7. Select the folder tool and insert one folder by clicking inside the diagram window.
8. Label the folder My Folder.
9. Select the line tool in the upper toolbox and insert one line by clicking inside the diagram window.
10. Set one green end of the line to a small cross on the edge of the folder icon.
11. Set the other green end to a small cross of the ellipse.
12. Select the folder icon and move it with your mouse. The connected line should follow.
13. To export the diagram, right-click inside the diagram.
15. Name the file FirstDiagram.png and click OK.
16. Confirm the resolution dialog by clicking Export.
17. Open a new OpenOffice Writer document and insert the pixel graphic you stored into that document. You can follow the steps outlined in the previous exercises.
Summary

• You can create a screenshot of your whole desktop or a specific window, save it to a file, and insert it into an OpenOffice.org document.

• You can create a vector graphic with OpenOffice.org Draw and use it in your document.

• You can manipulate a pixel graphic with Gimp and use the new picture in your document.

• You can create a chart with Dia and use it in your document.
9 Browse the Web with Mozilla Firefox

Objectives

After you complete this chapter, you should be able to do the following:

• Describe the web browser features of Firefox.

• Describe the concept of bookmarks, tabbed browsing, and password management that make web navigation with Firefox easier.
9 Browse the Web with Mozilla Firefox

9.1 Introduction

The web browser of Novell Linux Desktop is called Mozilla Firefox (or Firefox for short).
In the 1990s, Netscape Communications Corp. made the source code of the Netscape Communicator browser freely available. The Mozilla web browser was developed from the Netscape source code. While the full Mozilla web browser includes a mail client, a news client, an IRC chat client and an HTML editor; the Mozilla Firefox browser is reduced to simple web browser functionality. This makes Firefox small and fast.

You can start Firefox with clicking the icon in the top panel.

![Firefox Icon]

Figure 9.1: The Icon of Firefox

As with other browsers, you can access a web site by entering its URL directly in the white input field at the top of the application window and then pressing Enter.

9.2 The Icon Bar

The icon bar displays a lot of icons. You should already recognize most icons because they are from Microsoft Internet Explorer or other common web browsers.
9.2 The Icon Bar

Figure 9.2: Navigation Icons of Firefox
9.3 Bookmarks

9.3.1 Managing Bookmarks

You can bookmark web pages that you visit frequently. In Bookmarks, you find the following items:

**Bookmark This Page** Creates a bookmark of the actual web page.

**Manage Bookmarks** Starts the bookmark editor (see Figure 9.3). You can easily sort the bookmarks by moving them with the mouse.

![Bookmarks Manager](image)

Figure 9.3: Manage Bookmarks in Firefox

To create a new bookmark folder, click **New Folder** in the bookmark editor. To improve the clarity of the bookmark list, you can insert a separator with the button **New Separator**.
9.4 Tabbed Browsing

Top-level bookmarks (directly under the Bookmarks folder, are listed in the Bookmarks menu of the main window of Firefox.

Bookmarks in the Bookmarks Toolbar Folder are displayed in the bookmark panel in the main window of Firefox and can be accessed with a single mouse click.

9.3.2 Importing Old Bookmarks

When you start using Firefox as your new web browser, you may want to keep using your “old” bookmarks. Virtually all web browsers offer the option to save the bookmarks to a file. Bookmarks saved in this way can be imported into the Firefox bookmark editor by selecting File → Import. An import wizard starts and leads you through the import process.

9.4 Tabbed Browsing

An interesting feature you may know from the commercial web browser Opera or from Mozilla/Netscape is “tabbed browsing.” You can open new web pages on different tabs instead of in different windows.

![Figure 9.4: Tabbed Browsing with Firefox](image)

To open a blank new tab, press $\text{Ctrl} + \text{N}$.

A page will be opened in a new tab. If you click on a link and press $\text{Ctrl} \text{ simultaneosly}$, the linked page will be opened in a new tab.

Click on the small cross icon at the right of the tab panel to close the active tab.
9.5 How to Configure Firefox

The configuration dialog for Firefox (see Figure 9.5) can be found in the Edit → Preferences... menu.

![Figure 9.5: Configuration Dialog of Firefox](image)

There are the five configuration sections available:

- **General**  Home page, colors, languages, proxies
- **Privacy**  History, saved form information, saved passwords, download manager, cookies, cache
- **Web Features**  Block popup windows, load images, Java, JavaScript
- **Downloads**  Download folder, file types
- **Advanced**  Accessibility, browsing, certificates

Submenus are indicated by a small triangle. You can open or close a submenu by clicking the triangle.
9.6 Password Manager

Many web sites are only accessible to registered users. Access is normally granted only to those who can authenticate themselves with a login and password. Firefox automatically detects those pages that have such access control.

The password manager appears after the first login to a secured area. It asks whether it should store the login data. Every time the same login page is accessed, the password manager automatically fills out the input fields, sparing the user typing effort.

![Password Manager dialog](image)

Figure 9.6: The Password Manager

In the configuration dialog in the section Privacy → Saved Passwords you can check at any time for sites for which the password manager has stored access information (View Saved Passwords). With the Clear button you can save all saved passwords.

Additionally you can enter a master password (Set Master Password...). A master password is used to protect sensitive information like site passwords. If you create a master password you will be asked to enter it once per session when Firefox retrieves saved information protected by the password.

9.7 Theme Manager

The appearance of Firefox can easily be altered through the Internet. Several Themes are available. These can be downloaded and installed by selecting Tools → Themes.

The Theme Manager starts. In the left area the installed themes are listed. On the right a preview image of the selected theme is shown, if available. To activate another theme, select a theme from the list and click the Use Theme button.
To install a new theme, click Get More Themes. A new Firefox window opens, and the theme web page of the Mozilla organization with a list of the available themes is shown. You can select a theme from the list. In the description of the chosen theme there should be an Install Now link. Select this link to install the theme.

**Exercise: Using Firefox as Your Web Browser**

This exercise assumes that you have access to the Internet from your test machine.

Do the following steps if you have access to the Internet:

1. Start Firefox by clicking the icon in the top panel.
2. Type http://www.digitalairlines.com/ in the address field.
3. Create a bookmark for this page by selecting Bookmarks → Bookmark This Page.
4. Create in the same way four more bookmarks of your choice and add them to the bookmark folder.
5. Start the bookmark editor by selecting Bookmarks → Manage Bookmarks.
6. Create a new bookmark folder by selecting the New Folder... icon in the bookmark editor.
7. Enter My Bookmarks as the name of the new folder and click OK.
8. Drag and drop your new bookmarks into the new folder.
9. Close the bookmark editor window.
10. Open a new tab by pressing Ctrl + T.
11. Enter gnome novell into the web search text box. Check how many pages the search engine Google finds.
13. Acknowledge the warning message by clicking Close Tabs.

Do the following steps if you don’t have access to the Internet:

1. Start Firefox by clicking the icon in the top panel.
2. Type into the address text field the following address:
   /usr/share/doc/autoyast2/html/index.html
3. Create a bookmark for this page by selecting Bookmarks → Bookmark This Page.
4. Click your middle mouse button on the Introduction link.
5. Create a bookmark for this page by clicking Bookmarks → Bookmark This Page.
6. Start the bookmark editor by selecting Bookmarks → Manage Bookmarks.
7. Create a new bookmark folder by selecting the New Folder... icon in the bookmark editor.
8. Type in My Bookmarks as the name of the new folder and click OK.
9. Drag and drop your new bookmarks into the new folder.
10. Close the bookmark editor window.
11. Close the Firefox window.
12. Confirm the warning message by clicking Close Tabs.
Summary

• You can navigate on the Internet using the Firefox web browser.

• You can use Firefox’s advanced features, such as tabbed browsing password manager and theme manager.

• You know where to find the configuration settings for Firefox.
10 Printing with Linux

Objectives

After you complete this chapter, you should be able to do the following:

- Describe the principles of the printing process in a Linux environment and print files on a local or networked printer.
- Control the printing process.
10 Printing with Linux

10.1 Printing Files

Printing in a multiuser system can be challenging because several users can send print jobs to a
printer at the same time. This is especially true in networked companies where many desktop com-
puter users send their print jobs to a few centralized printers.

You will not face this kind of challenge if you work on a private workstation locally connected to
a printer set up for your own personal use. Regardless of the situation, the Linux printing system
is always the same. The Linux print system can handle a huge network with hundreds of desktop
computers and centralized, networked printers as easily as it does a personal, stand-alone desktop
with a directly connected printer.

To organize printing, several programs are placed between the user and the printer:

- From a printing dialog, the user selects a printer, determines the number of copies, and makes
  other settings.
- The print daemon receives the print job, places it in a queue, and successively sends print jobs
  from the queue to the printer.
- A series of utilities monitors printing. Print queues can be viewed and manipulated with these
tools.

Normally, one print queue is set up for each printer. However, it can be useful to have several print
queues for the same printer. For example, you may want to set up different print queues for different
print resolutions or, especially with color printers, for different print drivers (color or monochrome).
One physical printer can have more than one configured queue providing direct access to special
printer functionality. The user dialog can list multiple print queues, each of which uses a different
configuration setting even though all the queues are connected to the same printer. These basics,
which at first look very complicated, ensure that a user can send print jobs at any time and not notice
anything of the actual processing going on in the background. The print jobs are saved in the queue
and successively processed by the print daemon – filtered and sent to the printer. The programs
relevant to the user are explained below.

This document does not cover the detailed setup for printers or even network printing needs. It
assumes that you had a printer available when you installed Novell Linux Desktop. This printer
should have been detected and configured automatically by YaST. If you need special assistance or
if your printer was not detected, you can refer to the Appendix in this kit or to the Novell Linux
Desktop documentation.
The rest of this chapter assumes that your printer has been detected and configured during system installation just as it would have been with a Microsoft Windows Installation.

10.2 The Print Dialog

If you click the Print button in an application or select File → Print from the menu, a dialog for print settings is displayed. The window that opens varies slightly from one application to another.

There is a special Gnome dialog, which some applications use. It has three tabs:

**Job** You can specify the print range and the number of copies.

![Figure 10.1: The Job Tab of the GNOME Print Dialog](image)
10 Printing with Linux

**Printer** You can specify the printer you want to use.

![Printer Tab of the GNOME Print Dialog](image)

Figure 10.2: The Printer Tab of the GNOME Print Dialog

**Paper** You can specify the paper size, the borders, the orientation, the number of pages you want to print on one paper and the paper tray.

![Paper Tab of the GNOME Print Dialog](image)

Figure 10.3: The Paper Tab of the GNOME Print Dialog
Some applications ship with proprietary print dialogs. However, the most important settings are the same:

- **Printer name**
  Enter the printer (or the queue) to address. The system administrator defines the printer (queue) and its name. If this option is not specified, the default printer is used. You should see an entry such as HPDeskjet940C, depending on the printer that was detected and installed during the initial setup of Novell Linux Desktop Personal.

- **Number of copies**
  Set the number of copies to print. If nothing is specified, one copy is printed.

- **Page selection**
  You do not always have to print all pages of a document. This option allows you to determine which pages to print (specify first and last page or a selection to print).

The Print dialog is similar to the main print dialog you are familiar with in Microsoft Windows systems.

Of course, you can also print straight from the command line with very specific options, but this option is out of the scope of this study kit.

### 10.3 Displaying Print Jobs

You can view the status of print queues in the print queue manager, which can be reached by selecting **System → Personal Settings → Printers**.
All available printers are shown in the opened window.

Double-click one of the printer queue icons.

Figure 10.4: All Available Printers

Figure 10.5: A Print Job Is Waiting
10.4 Deleting Print Jobs

The following information is shown in the dialog:

- Rank of the job in the queue (The first is on the top.)
- Name of the file
- Number of the job
- Owner
- Size of the file
- Status of the printing job

10.4 Deleting Print Jobs

Print jobs that have not yet been processed can be deleted and the currently active job can be interrupted. Generally, the user can only delete his own jobs.

To do this, select the print job in the queue window and click the trash can symbol on the icon bar. Alternatively, you can right-click the print job and select Cancel from the menu.

Again, this print job administration is very similar to Microsoft Windows.

Exercise: Printing with Linux

This exercise guides you through the printing process. It assumes that you had a printer powered on and connected to your computer while you installed Novell Linux Desktop.

1. Ensure your printer is powered on.
2. Launch Nautilus on an empty virtual desktop by double-clicking the icon tux’s Home on the desktop.
3. Double-click the Documents folder in your home directory.
4. Right-click the MyScreenshot.png file you created earlier and select Open With... → The GIMP. Gimp should start and the image should be shown in a new window.
5. Select File → Print from the Image menu.
6. Check your printout. It should show your desktop.
7. Close all Gimp windows.
8. Now, launch a new OpenOffice.org Writer document and type a few paragraphs of text.
9. Save your file in your Documents folder with a filename of Printing-Excercise.sxw.
10. Within the OpenOffice.org application, open the print dialog of OpenOffice.org by selecting File → Print.
11. Select your printer from the Name drop-down list.
12. Click the OK button to accept the default settings and initiate the printing process.
13. Check your printout to make sure it is what you expected.
14. Turn off your printer.
15. Move back to the OpenOffice document and redo the step to print the file to your printer.
16. You will, of course, not get a printout because your printer is turned off. Switch to another free virtual desktop, and open the print queue manager by selecting System → Personal Settings → Printers →; then double-click the printer icon.
17. Right-click the print job and select Cancel to remove the job.
18. Close all windows and switch back to your first virtual desktop

Summary

- You can print files from the Novell Linux Desktop to your printer with and without special printing dialogs.
- You can use the print queue manager to control the print jobs in the printer queue.
11 Advanced Linux File System Techniques

Objectives

After you complete this chapter, you should be able to do the following:

- Describe how to back up or archive files on Novell Linux Desktop.
- Explain how the Network File System (NFS) shares data in a network.
- Understand how to use Microsoft shares with SAMBA on a Linux system to collaborate with Microsoft Windows services.
- Know how to use iFolder on a Linux system to have your files available everywhere.
- Describe how to use Linux applications to burn CDs.
11 Advanced Linux File System Techniques

11.1 How to Archive Files with File Roller

With the program File Roller, you can collect multiple files or even entire directories into an archive. This can be very useful for backing up data or preparing data to be sent by floppy disk or e-mail.

One big advantage of using File Roller to back up files is that the directory structure in an archive is recreated after unpacking.

You can start File Roller from the Programs menu by selecting System Tools → Archive Files.

![File Roller User Interface](image)

Figure 11.1: The User Interface of File Roller

Before you can begin archiving files, you must first create a new archive. Click New to open a window in which to specify the path and name of the archive. The standard file format for archives
11.1 How to Archive Files with File Roller

in Linux is `.tar`. Tar files can become quite large, but you can *compress* them at a later time. File Roller carries out archiving and compressing in one step if you use `.tar.gz` (or `.tgz` for short) as the file format. File Roller can also handle the `.zip` format that is commonly used in Windows environments.

With the pulldown menu *Archive type* you can specify the file format. File Roller supports a lot of file formats. The most important are:

- Arj archives (`*.arj`)
- Java archives (`*.jar`)
- Lha archives (`*.lzh`)
- Tar archives (`*.tar, *.tar.gz, *.tgz, *.tar.bz2, etc.`)
- Compressed files (`*.gz, *.bz, *.bz2, *.lzo`)
- Zip archives (`*.zip`)
- Zoo archives (`*.zoo`)
- Rar archives (`*.rar`)

When choosing the archive type *Automatic*, the archive type is specified by the name extension of the file name.

When you click *New*, an empty archive is created at the given location. To fill the archive, drag the required files with the mouse from Nautilus into the white window.

You can open and view the contents of an existing archive (whether it is compressed or not) either directly by clicking the file in Nautilus or by starting File Roller and clicking the *Open* button. With the mouse, you can drag individual files from the archive window and place them in a Nautilus window. Alternatively, you can unpack the entire archive with the *Extract* button. If you select some files with the mouse before, only the selected files are extracted.

---

1 From *tape archiver*; originally this was developed for data backup on magnetic *tape*.  

©2004 Novell Inc., the leading provider of Information Solutions
Exercise: Archiving Files

The following exercise will demonstrate that the standard archive format *.tar does not compress files in the archive.

1. Open File Roller from the Programs menu by selecting System Tools → Archive Files.
2. To create a new archive, documents.tar, which contains your own Documents directory, click New.
3. Enter documents.tar in the Name box.
11.2 How to Use the Network File System (NFS)

4. Ensure you are in your home directory.
5. Ensure Automatic is selected from the Archive type drop-down list box.
6. Double-click the tux’s Home icon on your desktop to start Nautilus.
7. Drag the Documents folder from your home directory to the File Roller window.
8. Close the open windows.
9. Double-click the tux’s Home icon on your desktop to start Nautilus again.
10. How large is the archive you just created?
11. Now, create a compressed archive, documents.tar.gz, which also contains your own documents directory. Use steps similar to those above, but create an Archive type of Automatic with a name of documents.tar.gz in your home directory.
12. How large is the compressed archive?

11.2 How to Use the Network File System (NFS)

11.2.1 A Brief Description of the Network File System NFS

This section briefly introduces the NFS (Network File System), which is widely used in the UNIX and Linux world. In an intranet, it is frequently useful to make data on one computer directly accessible from other computers. For this purpose, the system administrator mounts the file systems of one computer on the file system of another one.

Example: If a user wants to run an application on a remote host using the data from the home directory on the local host, the data could first be transferred to the remote host. However, everything would be easier if the content of the home directory on the remote host matched the home directory on the local host. This is what NFS does; the actual home directory of the user on the local host is empty. The home directory on the remote host is mounted on the network (see Figure 11.3 on the next page). In principle, the user does not know if the files with which he is working are located on his own computer or on a remote one.

Using NFS, it is now also possible to exchange data with other users. The computers must be connected to the network and the owners must allow access to the files and directories to be exchanged by granting file permissions.
11.3 How to Use Windows Shares

11.3.1 Preliminary Note

In a Windows operating system, files and directories can be shared with other members in the network. The files made available for general use in the network are usually referred to as shares. Linux is also able to handle such shares.

With a default installation of Novell Linux Desktop, you can access Windows shares. However, if you want to make one of your Linux directories available for the Windows users in your network, you have to install the “Samba” service from the Novell Linux Desktop CDs.
11.3.2 Accessing Shares and Other Services

The network shares can be viewed and accessed in Nautilus. To do this, double-click the Computer icon on the desktop.

When Nautilus is started, it displays a number of available devices, including the Network service (see Figure 11.4).

![Computer window with devices](image)

Figure 11.4: The Available Devices

Double-click the Network icon. Nautilus opens a new window with the computers of your workgroup that provide shares. It also displays the Windows Network icon. (see Figure 11.5 on the next page.)
Double-click a workgroup to display the hosts in the workgroup. Hosts that are assigned a name are displayed with their names. Hosts without a name are displayed with their IP addresses (see Figure 11.6).
11.4 How to Share Files with Novell iFolder

Double-click a host icon to view the *shares* available on the host (see Figure 11.7). If a user authentication is required for a share, Nautilus will query the login name and password before accessing the share.

![Windows Network: da2]

Figure 11.7: Access a Share on Workstations DA2

11.4 How to Share Files with Novell iFolder

11.4.1 What Is Novell iFolder

You are working on a workstation in your office. You are working on your private computer when working from your home office. You are working on a notebook when visiting customers.

In this case you need to have all your files, the newest versions, available on each of your computers. One possibility is to save your home directory on CD, DVD, or a memory stick every day.

Another possibility is to use Novell iFolder.

iFolder synchronizes a specific directory every five seconds to an iFolder server. You have to authenticate at this server and then you can access all stored files like local files.
11.4.2 Configure iFolder

You can start the iFolder client by selecting Accessories → Novell iFolder in the
Programs menu.

Before you can use iFolder the first time, you have to configure the client.

In the first dialog you have to enter your user ID, your password and the name of the iFolder server. If you
do not want the client to create an icon for iFolder on your desktop, you can deactivate the option
Place a shortcut to the iFolder on the desktop. Click Login to go ahead.

![Login Dialog of Novell's iFolder](image)

Figure 11.8: Log in Dialog of Novell's iFolder

You need to specify a directory on your local workstation, which iFolder has to synchronize. Enter
a directory name. If the directory does not exist, it is created. Click the OK button.
11.4 How to Share Files with Novell iFolder

In the next configuration dialog you can choose whether you want iFolder to login automatically at startup and if you want to encrypt the synchronized files.

Figure 11.9: Specify the Local iFolder Location

Figure 11.10: Setup Dialog of iFolder
If you chose file encryption, you have to enter a pass phrase for the encryption in the next dialog.

The hint will be shown, if you can not remember your password.

It is not recommended that you activate the Remember pass phrase option. iFolder will not ask you for the pass phrase anymore at the start. This is not a secure feature.

### 11.4.3 Use iFolder

If you activated the Place a shortcut to the iFolder on the desktop option, an icon is created on your desktop (see Figure 11.8 on page 156).
When you double-click that icon, a Nautilus window opens and the content of your iFolder directory is displayed. The handling of this window is the same as that of local Nautilus windows.

Another iFolder icon is shown in the panel notification area. A single click on that icon opens a window with three tabs. The tab View Activity is activated. Here you can see a log of the synchronization of your iFolder account.

![The Log File of the iFolder Activity](image)

Figure 11.13: The Log File of the iFolder Activity
The tab Account Information shows you the most important information about your iFolder account.

Figure 11.14: All Important Information about Your iFolder Account
11.4 How to Share Files with Novell iFolder

The tab Preferences shows some additional information, such as the synchronization times.

When you start iFolder after a logout, you have to select Accessories → Novell iFolder in the Programs menu.

First you have to authenticate against your iFolder server, and then you have to enter your pass phrase for the file encryption, if you selected this feature.

To log out, right-click the iFolder icon in the panel notification area and select Logout from the pop up menu.
11.5 How to Manage CDs

11.5.1 Starting K3B

K3B is the program for burning CDs. You can find the entry in the Programs menu under Multimedia → CD Burner.

![K3B User Interface](image)

Figure 11.16: The K3B User Interface

K3B can work in four modes. The mode you use will depend on the type of project you are working on:

- **New Audio CD Project** Create a new audio CD with music files.
- **New Data CD Project** Create a data CD to store data files.
11.5 How to Manage CDs

**New Data DVD Project** Create a data DVD to store data files.

**Copy CD**... Copy a CD.

The look and feel of the first three modes is very similar. The last mode starts a wizard that leads you through the copy process.

### 11.5.2 Create a New Audio or Data CD

The two areas on the top of the window are used for navigating the file system. The area on the bottom shows you the content of the CD you will burn.

You can select a file or a directory from one of the top areas and drag it with the mouse into the bottom window area.

If you want to create an audio CD, choose the option to create a audio CD with your music files. By default, K3B can read the WAV, Ogg Vorbis, and MP3 formats.

![Figure 11.17: Create a New Audio CD](image)
After selecting your files, click the Burn button in the bottom right corner. A dialog appears that differs depending on the kind of project (see Figure 11.19 on the next page), but the main options are equal.

**Burning Device** Select your CD/DVD recorder.

**Writing Mode** Choose the writing mode. You can burn your entire disc at once (DAO), burn each track individually (TAO), burn raw data (RAW), or let K3B decide (Auto).

**Option Simulate** If you just want to test the burning process, select this option.

**On the fly** If you want to burn directly, without making a copy on the hard disk first, select this option.

**Burnfree** If your CD recorder supports a “burnfree” mode and you want to use it, select this option.
11.5 How to Manage CDs

**Only create image** If you just want to create an ISO image on your hard disk without burning this image on a CD/DVD, select this option.

In most cases, you do not need to change anything and you can Click the **Burn** button.

![Figure 11.19: The Burn Dialog for Creating a New Data CD](image)

©2004 Novell Inc., the leading provider of Information Solutions
11.5.3 Copy a CD

If you choose Copy CD... in the main menu, you do not need to select the files you want to copy. The Burn dialog appears (see Figure 11.20).

![Burn Dialog for Copying a CD](image)

Figure 11.20: The Burn Dialog for Copying a CD

Here you have nearly the same configuration possibilities as described in section 11.5.2 on page 164. But you also have to select a CD Reader Device and a Copy Mode:

- **Normal Copy**: Copies the CD track by track.
- **Clone Copy**: Copies the CD byte by byte.
11.5 How to Manage CDs

11.5.4 More Tools

Some more interesting features can be found in the Tools menu of the main window of K3B:

**CD → Erase CD-RW...** Erase a rewriteable CD-RW.

![Erase CD-RW](image)

**Figure 11.21: Clear a CD-RW**

CD → **Burn CD Image...** Burn an ISO image (made with the Only create image option in the burn dialog or downloaded from the Internet) to CD.

DVD → **Copy DVD...** Copy a complete DVD.

DVD → **Format DVD-RW/DVD+RW...** Clear a rewriteable DVD-RW or DVD+RW.

DVD → **Burn DVD Image...** Burn an ISO image (made with the Only create image option in the burn dialog or downloaded from the Internet) to DVD.
Summary

We do not provide an exercise in this chapter because system configurations will vary among users of this kit. If your system, for instance, is networked with a Microsoft network infrastructure, you can check out the SAMBA functionality. If your machine is networked with a Novell network, you can check the NFS and SAMBA functionalities. If you have a CD or DVD writer, you can check out K3B to create CDs from your new Novell Linux Desktop.

For more information, you can refer to the extensive Linux documentation.

- You understand the archive formats of Linux and how to use them.
- You have a basic understanding of network file systems and how to use them from your Linux system.
- You are familiar with the CD and DVD burning capacities of Linux.
12 Manage Novell Linux Desktop

Objectives

After you complete this chapter, you should be able to do the following:

• Explain when you need to use the root account to perform system adjustments.

• Describe how to work with processes on Novell Linux Desktop system to terminate misbehaving processes.

• Understand how to install new software on your system.
12.1 How to Use root

12.1.1 What root Is

If you have worked with Windows NT, 2000, or XP, you know that they both employ a user called administrator. In Linux the administrator of the system is called root and is allowed to do everything.

12.1.2 Describe When to Use root

You have to switch to the root user account if you want to change important system settings. For example, you must be root to

- Configure server services
- Install or remove software
- Manage users and groups
- Change hardware configurations
- See system logs

Of course you can log in as root and work as though you were a normal user, but for security reasons it is not recommended. The fewer programs run with root permissions the better.

⚠️ Attention! We strongly recommend that you avoid logging in to Linux as root. As a normal user, you do not have the permissions to delete important system files. Normal users can only affect the files in their home directory. If you logged in as root, however, you have access to the entire file system and could, therefore, destroy the whole system. Thus, you should usually be logged in as a normal user. Switch to the root user account when you need to use a program that requires root permissions.
12.1 How to Use root

12.1.3 How to Log In as root From the Desktop

You can switch to the root user account in several different ways:

- There are some programs available in the Programs and in the Systems menu that require root permissions. If you select Administrator Settings from the System menu the YaST configuration tool starts. To use YaST you have to be root. Accordingly, a dialog opens where you have to enter the root password.

![Figure 12.1: Become root to Start YaST](image)

- You can start a graphical application using the command line (System menu → Run Program...). To start the application with root permissions, enter kdesu program_name. The authentication dialog (Figure 12.1) appears. After you enter the root password, the application starts.

- If you are working in a shell (e.g. Programs menu → System Tools → Terminal, you can switch to root by entering the su – command. If you want to start a graphical application out of the shell, you can use the sux – command instead (Figure 12.2 on the next page).

  While entering the password nothing is shown at the prompt; you have to type blind.

  You can see that you are root at the shell prompt. To leave the administrator mode, you enter the exit command.
12.2 How to Manage Processes

12.2.1 Describe What a Process in a Linux System Is

The underlying program on a computer is the operating system, also known as the kernel. On top of the kernel run a series of programs. These are referred to as processes. When a process is started, it receives its own number from the kernel by which it can be addressed. This is called either a process ID or a process number.

Processes themselves do not have any access to the hardware. If they need system resources, such as storage space or cpu time, they must request the resource from the kernel. The kernel thus ensures, for example, that a program does not use memory that may already be in use.

Because Linux is a multitasking operating system, more than one process can run simultaneously. In actuality, they do not really run simultaneously; they only appear to do so. A part of the kernel, the scheduler, switches between individual programs many times a second and assigns computing time to each of them. The user is unaware of these changes, although processing gets slower if too many programs are running simultaneously.
12.2 How to Manage Processes

Processes may adopt different states, such as:

- **active** (running)
  The process is busy running a particular task.

- **resting** (sleeping)
  The process awaits a specific result, such as a user pressing a key or the end of a subroutine.

- **stopped**
  The process has been temporarily stopped.

12.2.2 Using Tools to Terminate Processes

To quit an application, you can choose **File → Quit** from the menu bar, or you can press the “X” button in the top right corner of the window.

**Window List**

The window list in the bottom panel works just as the task bar does in Microsoft Windows. The different ways an application can be closed under Linux are described in the following subsection.

You can kill an application by clicking the entry in the taskbar with the right mouse button. You can choose **Close** from the pop-up menu.
System Monitor

To display currently running processes, use the System Monitor; which can be found in the Programs menu under System Tools → System Monitor.

The System Monitor window consists of two tabs. The Process Listing tab lists all running processes (see Figure 12.4), as described below. The Resource Monitor tab shows the system load (the load on the processor and the memory).

![System Monitor Window](image)

Figure 12.4: All Currently Running Processes for the Current User
12.2 How to Manage Processes

The following information is displayed in the process table:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Name</td>
<td>Name of the process</td>
</tr>
<tr>
<td>User</td>
<td>Processor load caused by the process</td>
</tr>
<tr>
<td>Memory</td>
<td>Actual memory occupied</td>
</tr>
<tr>
<td>X Server Memory</td>
<td>Actual memory occupied for the graphical output</td>
</tr>
<tr>
<td>Nice</td>
<td>Priority of the process when allocated computer time by the kernel</td>
</tr>
<tr>
<td>PID</td>
<td>Number of the process (process ID)</td>
</tr>
</tbody>
</table>

Table 12.1: System Monitor Information

To end a process, click the process line; then click End Process.

★ Note! A user can kill only his or her own processes (except for the system administrator root).

xkill

You can also kill a graphical application using the xkill program. You can start it by entering xkill in the command line (System menu → Run Program...).

The mouse pointer changes to a skull and you can move it to the window of the application you want to kill. You can click anywhere on the window to kill the application.

✎ Exercise: Terminate Processes

1. Start the command line via System → Run Program...; then enter xeyes and click Run.
2. Kill xeyes by right-clicking the entry in the taskbar; then select Close.
3. Start xeyes again by selecting System → Run Program...; then enter xeyes and click Run.

4. Start the System Monitor by selecting System Tools → System Monitor from the Programs menu.

5. Ensure the Process Listing tab is selected.

6. Enter eyes in the text field Search and press Enter.

7. Ensure that the process called xeyes is selected.

8. Click Kill.

9. In the confirmation dialog, click End Process.

10. Start xkill by selecting Run Program... from the System menu; then enter xkill and click Run.

11. Move the mouse pointer over the System Monitor window and click once on it.

12.3 Install and Uninstall Software

In the following section you will frequently see the term “package.” A package includes the files you need for a special application and additional information such as:

- Information about dependencies between packages (for example, package A is required to install package B)
- A description of the application
- Information about the author of the package
- ...

The common package format of Novell Linux Desktop is RPM (RPM Package Manager). The executable files in a package are compiled. Because of this, you need to verify which Linux distribution the package is intended for.

To install and uninstall software, you have to switch to the root user account. (Be aware that there are different ways of installing and uninstalling programs.)
12.3 Install and Uninstall Software

12.3.1 Software from the Novell Linux Desktop CD/DVD

If you want to install (or deinstall) software from your Novell Linux Desktop CDs or DVD, you have to start YaST by selecting \texttt{System} $\rightarrow$ Administrator Settings.

![YaST Main Menu](image)

Figure 12.5: The YaST Main Menu
In the right part of the window, you will see the **Install and Remove Software** option. Click this option. Another window opens (see Figure 12.6).

![Figure 12.6: Installing and Uninstalling Software with YaST](image)

Because many packages are delivered with Novell Linux Desktop, you have several filters to choose from. You can choose the filter from the pull-down menu in the top left corner. The following filters are available:

**Selections**  Shows only the installed packages.

**Package Groups**  Shows all software that is available on the known installation medias.

**Search**  Shows a dialog where you can enter a search term and location where you want YaST to search.

**Installation Summary**  Shows all the packages with the marked status.
12.3 Install and Uninstall Software

In many cases, you already know the name of the package you want to install. This allows you to use the Search filter. Enter the package name, parts of the package name, or some relevant keywords into the Search text field; then press Search. The matched packages are listed in the right area of the window. The installation state is indicated by a small symbol in front of the package name. The most important symbols are shown in Figure 12.7. An overview about all possible symbols can be displayed using the Help → Symbols menu.

![Table of Symbols](image)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>☑️</td>
<td>Do not install. This package is not installed and it will not be installed.</td>
</tr>
<tr>
<td>☑️</td>
<td>Install. This package will be installed. It is not installed yet.</td>
</tr>
<tr>
<td>☑️</td>
<td>Keep. This package is already installed. Leave it untouched.</td>
</tr>
<tr>
<td>☑️</td>
<td>Update. This package is already installed. Update it or reinstall it (if the versions are the same).</td>
</tr>
<tr>
<td>☑️</td>
<td>Delete. This package is already installed. Delete it.</td>
</tr>
<tr>
<td>☑️</td>
<td>Taboo. This package is not installed and should not be installed under any circumstances, especially not because of unresolved dependencies that other packages might have or get. Packages set to &quot;taboo&quot; are treated as if they did not exist on any installation media.</td>
</tr>
<tr>
<td>☑️</td>
<td>Protected. This package is installed and should not be modified, especially not because of unresolved dependencies that other packages might have or get. Use this status for third-party packages that should not be overwritten by newer versions that may come with the distribution.</td>
</tr>
</tbody>
</table>

Figure 12.7: The Most Important YaST Software Installation Symbols

Click on the symbol of the package you want to install until the “install” symbol appears; then click Accept.

You may see a dialog indicating that the dependencies between packages cannot be solved and that additional packages need to be installed. In most cases you can simply acknowledge this dialog. If the wrong CD or DVD is in your CD/DVD drive, a warning appears.
12 Manage Novell Linux Desktop

12.3.2 Install Foreign RPMs

If you have downloaded a RPM package or you have a CD with additional RPM packages, you can start the installation with Nautilus. Just browse to the package and double-click on the icon.

You are asked to enter the root password. The installation program, called Red Carpet, then starts automatically.

![Red Carpet RPM File Installation](image)

Figure 12.8: Red Carpet RPM File Installation

After clicking Continue, the RPM file is installed.

12.3.3 Compile and Install Source Files

The programs in an RPM package are compiled. Because of this, an RPM package is specific for one Linux supplier or distribution. Sometimes, you can use a RPM package designed for another distribution, but many times they will not work.
If you want to install an application that is not available for your distribution, you need to compile the source files on your own. The tools you need for compiling programs are included on the Novell Linux Desktop CDs.

12.4 Update the System

If you bought a licence for the Novell Linux Desktop, you are able to update your system automatically. Without this, you have online support only for 30 days.

The tool you use for this is Red Carpet (also known as ZENworks Linux Management). To start it, select Software Update from the Systems menu. Then, enter the root password.

![Update your System with Red Carpet](image12.9.png)

You can activate Red Carpet during the installation after the test of the internet connection when looking for new updates. You can also activate it after installation by selecting File → Activate.
You will be required to enter your mail address and the activation code. Click Activate to start the activation.

To start the update process, click Run Now.

**Summary**

- You know how to use the root account for system-wide configuration and maintenance tasks.
- You know how to terminate processes and applications on a Linux system.
- You understand how to install applications on your Linux system.
13 Finding Help and Training Support

Objectives

After you complete this chapter, you should be able to do the following:

- Describe how to find help for Novell Linux Desktop on your system and the Internet and how to get more information on advanced functions.
- Describe how to find training for Novell Linux Desktop and Novell services running on Linux and how to register for the training you need.
13 Finding Help and Training Support

13.1 Help for Novell Linux Desktop

Novell Linux Desktop provides its own help system – *Novell Linux Desktop Help Center*. To access the Help Center, select *User’s Manual* in the top panel. A window opens and displays the help texts.

![The Help for Novell Linux Desktop](image)

Figure 13.1: The Help for Novell Linux Desktop

Help programs are available in most Gnome applications and can be started by pressing `F1`. Because the help programs use HTML format, you can follow any embedded hyperlinks by clicking the desired entry in the table of contents.
13.2 Help on the Internet

Help is usually available on the Internet, especially for more complex challenges. The Internet, which has greatly contributed to the spread of Linux, now offers a very wide variety of sources for expert know-how on all questions concerning Linux.

Detailed help for Novell Linux Desktop-specific issues is available in the SUSE Support Database:


You can find general help with Linux at these addresses:

http://www.linux.com/
http://www.linux.org/docs/index.html
http://www.tldp.org/
http://www.llp.fu-berlin.de/lsoft/index.html

In many cases you can find the right help by using an Internet search engine such as Google.

13.3 How to Get Linux Training

Novell offers a range of Linux Training Certifications.

For Novell offerings, especially the Novell Certified Linux Engineer and the new Novell Certified Linux Professional, you can bookmark the following web site and visit it from time to time for updated Novell Linux training offerings:

http://www.novell.com/training/

In spring 2005 there will be online training available on the Novell web site for Linux beginners. It will cover Novell Linux Desktop basics, Evolution, and the components of OpenOffice.

To register for training, you can use the Novell Training Locator to find a certified Training Provider near you:

http://www.novell.com/training/locator/SearchAdvanced.jsp
13 Finding Help and Training Support

Summary

- You can find help directly on your system and on the Internet for all aspects of your Novell Linux Desktop.

- You can search the web site from Novell to find out more about training and certification offerings.

- You can use the Novell Training Locator to find a Training Provider near you.
14 Take a Break...

Objectives

After you complete this chapter, you should be able to do the following:

- Describe how to play audio and MP3 files or watch a movie on Novell Linux Desktop.
- Describe how to use some of the games installed with Novell Linux Desktop.
14.1 Listen to the Music...

14.1.1 Playing an Audio CD

To listen music, insert an audio CD into your CD drive. Then run the application to play the CD by selecting Multimedia → CD Player from the Programs menu.

![Figure 14.1: Play an Audio CD](image)

At the bottom of the window are buttons similar to those found on a CD player.

If you have internet access, the CD player tries to identify the name of your CD via CDDB.

14.1.2 Playing MP3 Files

To play MP3 files or other audio files (such as Ogg Vorbis or WAV), run the RealPlayer program. You can do this by selecting Programs → Multimedia → RealPlayer 10.

Before you can start RealPlayer the first time, you have to configure it. A wizard helps you through the configuration process.
14.1 Listen to the Music...

Figure 14.2: The RealPlayer Configuration Wizard

Follow the prompts to configure RealPlayer.

The default RealPlayer window is shown in the following figure.

Figure 14.3: RealPlayer Configured
You can open a file on your hard disk by selecting **File → Open File...** With **Open Location...** you can open a file somewhere in the Internet by entering the URL.

If you double-click an MP3 file in Nautilus, RealPlayer starts automatically.

RealPlayer playing a sound file is shown in the following figure.

![RealPlayer playing a sound file](image)

Figure 14.4: Play an MP3 File in RealPlayer

### 14.1.3 Control the Volume

To control the volume, you can use the loudspeaker icon in the top right corner. Clicking it opens a slider to control the volume.

![Volume slider](image)

Figure 14.5: Pump up the Volume
14.2 Watching Movies

If you want to manage the volume of the different sound-devices in detail, select Multimedia → Volume Control from the Programs menu.

![Volume Control](image)

Figure 14.6: Be the DJ of your Computer

For stereo devices you have two sliders. On for the right and one for the left channel.

You can lock and mute devices. You can also configure devices you want to use for recording.

14.2 Watching Movies

Although it is technically possible to watch movies with Linux, a lot of legal issues must be considered. The movie on a DVD is encrypted and cracking encrypted information is illegal. Applications are available on the Internet to watch DVDs. However, these programs are illegal; therefore Novell is not allowed to include them in the distribution.

Another problem is proprietary file formats. Quicktime is a format that was developed by the Apple Computer, Inc. Because Apple has not made Quicktime available for Linux, you must use either illegal tools from the Internet or use an emulation utility like CrossOver Office from Codeweavers Inc. to view a Quicktime movie.
You can watch Real movies without any problems using the Linux version of the Real Player as described previously.

Figure 14.7: Watch a Movie with Real Player
You can also watch MPEG or AVI movies without problems. The program for watching them is called Totem and can be started from the Programs menu → Multimedia → Totem Movie Player.

Figure 14.8: Watch an MPEG Movie with Totem Movie Player
14.3 Games

Some games are included in the Novell Linux Desktop distribution. You can find them in Games within the Programs menu. This course describes only some of them.

14.3.1 Iagno

Iagno is an Othello game for Gnome. To start a game select Game → Start Game.

At first, Iagno is configured for two human players. If you want to play alone against the computer, select Settings → Preferences → tab Players.

Figure 14.9: Iagno is an Othello game
14.3 Games

The aim of Iagno is to get the majority of your color discs on the board at the end of the game.

A move consists of “outflanking” your opponent’s disc(s), then flipping the outflanked disc(s) to your color.

14.3.2 Gnome Mines

Gnome Mines is the Gnome version of Minesweeper. To start it, select Programs → Games → Mines

![Figure 14.10: The Gnome Version of Minesweeper](image)

You have to find the bombs hidden behind the grey boxes on the board. If you click a field with no bomb hidden, a number shows you how many bombs are adjacent to this field. If you click a field with a bomb, you loose.
14.3.3 Nibbles

Nibbles is a game for one to four players. You can start it by selecting Programs → Games → Nibbles. To start a new game, select Game → New Game.

You are a worm and you have to collect diamonds. For each diamond you will grow a little bit. You can control the worm with the cursor keys. You are not allowed to touch the walls, another worm, or your own tail.

If you want to play with more than one player, select Settings → Preferences.
14.3.4 Same

Same is a strategy game. You can start Same by selecting Programs → Games → Same Gnome.

![Same Game Interface](image)

Figure 14.12: Remove Balls with the Same Color

You can remove two or more balls with the same color being next to each other. The aim of the game is to remove all balls without any carryover.
14.3.5 Solitaire

Solitaire is similar to the Windows Solitaire game. To play Solitaire, select Programs → Games → Solitaire.

![Figure 14.13: The Gnome Version of Solitaire](image)

There are lot of different card games available on the Game → Select... menu. A description of the rules you can find in the online help (Help → Contents).

Summary

- You can play audio CDs and other music files on your Novell Linux Desktop system.
- You can watch movies with players freely available for the Linux platform.
- You can play games on your Novell Linux Desktop.
Appendix
# A Alternatives for Windows Applications

The following tables give you an overview about Windows applications and their Linux counterparts. The column *Where to Find* contains the path to the application in the Gnome menus. If Novell Linux Desktop does not contain the program, a link to the home page of the application is given instead.

## A.1 Office Applications

<table>
<thead>
<tr>
<th>Windows Application</th>
<th>Linux Application</th>
<th>Where to Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS Word</td>
<td>OpenOffice.org Writer</td>
<td>Programs → Office → Word Processor</td>
</tr>
<tr>
<td>MS Excel</td>
<td>OpenOffice.org Calc</td>
<td>Programs → Office → Spreadsheet</td>
</tr>
<tr>
<td>MS Powerpoint</td>
<td>OpenOffice.org Impress</td>
<td>Programs → Office → Presentation</td>
</tr>
<tr>
<td>MS Access</td>
<td>Rekall</td>
<td><a href="http://www.rekallrevealed.org">http://www.rekallrevealed.org</a></td>
</tr>
<tr>
<td>Acrobat Reader</td>
<td>Acrobat Reader</td>
<td>Programs → Office → Document Viewer</td>
</tr>
<tr>
<td>Quicken</td>
<td>GNUCash</td>
<td><a href="http://www.gnucash.org/">http://www.gnucash.org/</a></td>
</tr>
<tr>
<td>MS Editor</td>
<td>gedit</td>
<td>Programs → Accessories → Text Editor</td>
</tr>
<tr>
<td>Calculator</td>
<td>Gcalctool</td>
<td>Programs → Accessories → Calculator</td>
</tr>
</tbody>
</table>

Table A.1: Office Applications
A.2 Internet Applications

<table>
<thead>
<tr>
<th>Windows Application</th>
<th>Linux Application</th>
<th>Where to Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer</td>
<td>Firefox</td>
<td>Programs → Internet → Firefox Web Browser</td>
</tr>
<tr>
<td>Outlook Express</td>
<td>Evolution</td>
<td>Programs → Office → More → Evolution</td>
</tr>
<tr>
<td>MSN Messenger, Yahoo Messenger, ICQ, ...</td>
<td>Kopete</td>
<td>Programs → Internet → Chat</td>
</tr>
<tr>
<td>Frontpage Express</td>
<td>OpenOffice.org Writer</td>
<td>Programs → textttOffice → Word Processor: File → New → HTML Document</td>
</tr>
</tbody>
</table>

Table A.2: Internet Applications

A.3 Data and File Management Applications

<table>
<thead>
<tr>
<th>Windows Application</th>
<th>Linux Application</th>
<th>Where to Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Explorer</td>
<td>Nautilus</td>
<td>Programs → Accessories → File Manager</td>
</tr>
<tr>
<td>WinZip</td>
<td>File Roller</td>
<td>Programs → System Tools → Archive Files</td>
</tr>
<tr>
<td>Nero, WinOnCD, CloneCD, ...</td>
<td>K3B</td>
<td>Programs → Multimedia → CD Burner</td>
</tr>
</tbody>
</table>

Table A.3: Data and File Management Applications
### A.4 Multimedia Applications

<table>
<thead>
<tr>
<th>Windows Application</th>
<th>Linux Application</th>
<th>Where to Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Media Player</td>
<td>Totem</td>
<td>Programs → Multimedia → Totem Movie Player</td>
</tr>
<tr>
<td>Adobe Premiere</td>
<td>MainActor</td>
<td><a href="http://www.mainconcept.de">http://www.mainconcept.de</a></td>
</tr>
<tr>
<td>RealPlayer</td>
<td>Real Player</td>
<td>Programs → Multimedia → RealPlayer 10</td>
</tr>
<tr>
<td>Audio Editing</td>
<td>Audacity</td>
<td><a href="http://audacity.sourceforge.net">http://audacity.sourceforge.net</a></td>
</tr>
</tbody>
</table>

Table A.4: Multimedia Applications

### A.5 Publishing Applications

<table>
<thead>
<tr>
<th>Windows Application</th>
<th>Linux Application</th>
<th>Where to Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adobe Illustrator</td>
<td>Sodipodi</td>
<td>Programs → Graphics → More → Sodipodi</td>
</tr>
<tr>
<td>Adobe Photoshop</td>
<td>Gimp</td>
<td>Programs → Graphics → GIMP Image Editor</td>
</tr>
<tr>
<td>Adobe PageMaker</td>
<td>Scribus</td>
<td><a href="http://www.scribus.net/">http://www.scribus.net/</a></td>
</tr>
<tr>
<td>Photo Archiving</td>
<td>gThumb</td>
<td>Programs → Graphics → Thumbnail Image Browser</td>
</tr>
<tr>
<td>Image Scanning</td>
<td>Kooka</td>
<td>Package kdegraphics3-scan on the Novell Linux Desktop CD, not installed by default</td>
</tr>
</tbody>
</table>

Table A.5: Publishing Applications
A Alternatives for Windows Applications
B Detailed Network Configuration for Novell Linux Desktop

Objectives

After you complete this chapter, you should be able to do the following:

• Understand the concept of network configuration in Novell Linux Desktop and apply it to your network if it has not been automatically configured for you during installation.
B Detailed Network Configuration for Novell Linux Desktop

B.1 When to Configure

During the installation or at any time after that, you can configure your network connection.

During the installation If you are at the Network Configuration dialog (see Figure B.1) and you want to configure a fixed IP address instead of letting DHCP specify it, click the Network Interfaces link or use the Change... pulldown menu.

![Network Configuration](image)

Figure B.1: Network Configuration

After the installation You can change your network configuration settings using YaST. Start YaST by selecting System → Administrator Settings. You must type in the root password before the YaST window appears. (You used novell during the initial installation of your test machine.) Select Network Devices and click the Network Card icon.

From this point, there is no difference between the network configuration either during or after the installation.
B.2 Change the Network Configuration

B.2.1 Select a Network Card

The Network cards configuration dialog appears, listing all available network cards that have not been configured. If you have only one network card, this text area is empty. All configured network cards are listed in the lower portion of the dialog.

![Network Cards Configuration](image)

**Figure B.2: The Configured Network Cards**

First, you need to change the configuration of the network card being configured for DHCP. To do this, click **Change**... A window appears listing the configured network cards. If you have only one network card, only one entry appears in the text area, and the card is activated.
To change the setting of an activated card, click **Edit**. The **Network address setup** dialog appears.

You can change the automatic DHCP configuration for one of the following reasons:

1. Your network does not offer DHCP services.
2. Your computer has a static IP address in your network.
3. You know the IP address of your DNS server.
4. You need to specify a default gateway (such as a router or a firewall).
B.2 Change the Network Configuration

B.2.2 Change the IP address

To enter a static IP address, select Static address setup. Enter your IP address in the IP Address text field and your network mask in the Subnet mask text field.

B.2.3 Change the Host Name

If you want to enter a static host name or specify your DNS name servers statically, go to the Network address setup dialog (see Figure B.4). Then select the Host name and name server button.

If your computer currently gets the information about the name servers through DHCP, a hint appears. Click Modify if you want to change the DNS information as well.
To enter a static host name, type the host name in the **Host Name** text field and the name of your domain in the **Domain Name** text field. If you do not want DHCP to change the name again, clear the **Change host name via DHCP** checkbox.
B.2 Change the Network Configuration

You can specify up to three name servers. Enter their IP addresses in the Name Server 1, Name Server 2, and Name Server 3 fields. You must also type in the names of the domains these servers are responsible for (Domain Search 1, Domain Search 1, and Domain Search 1. If you do not want DHCP to change these entries, clear the Update name servers and search list via DHCP checkbox.

Click OK to return to the Network address setup dialog (see Figure B.4 on page 209).

B.2.4 Change the Default Gateway

If you want to specify a default gateway, select Routing in the Network address setup dialog (see Figure B.4 on page 209).

In the following Default Gateway dialog, type the IP address of your gateway in the Default Gateway text field.

![Figure B.7: Specify the Default Gateway](image)

©2004 Novell Inc., the leading provider of Information Solutions 211
Clicking OK brings you back to the Network address setup dialog.

Click Next to close that dialog; then click Finish to save and apply your settings to the system. You can now close YaST and verify your new settings.

To verify your new settings, launch a Terminal session by clicking the third icon from the left in the KDE panel. The new hostname is shown as part of your system prompt. Enter `su` -; then provide your root password (secret for this study kit) to receive root permissions. Now, enter `ifconfig` to display the current interface configuration on your system. For your network card, which is most likely designated as eth0, you can verify the new IP settings.

Exit the su session and close the Terminal window.
C Detailed Configuration of the Print Management CUPS

Objectives

After you complete this chapter, you should be able to do the following:

• Understand when you need to manually change your printer environment so you can install a printer not detected during initial system installation.
C Detailed Configuration of the Print Management CUPS

C.1 When to Configure

During the installation or at any time later, you can configure your printer:

During the installation If you are at the Hardware Configuration dialog (see Fig. C.1) and your automatic detection is not correct, click the Printers link or use the Change... pull-down menu.

![Hardware Configuration Dialog](image)

Figure C.1: The Hardware Configuration

After the installation You can change your network configuration settings with YaST. Start YaST from the System menu → Administrator Settings. You have to type in the root password before the YaST window appears. (For this study kit you are provided novell as the root password.) Select Hardware and click the icon Printer icon.

From here there is no difference between configuring your printer during or after the installation.
C.2 Change the Printer Configuration

The upper part of the Printer Configuration dialog lists all automatically detected printers that have not been configured. If the printers cannot be detected automatically or if all printers are already configured, this text area displays only the Other (not detected) text. The lower part of the dialog lists all configured printers.

![Image of Printer Configuration dialog]

Figure C.2: The Printer Configuration

Automatically detected printers will be configured correctly by an automated process. If your printer is not detected, you have to configure it manually. To configure your printer, click the Configure... button.
C Detailed Configuration of the Print Management CUPS

You have to the type of your printer. If the printer is directly connected to your computer, you have to select one of the following types:

- Parallel printer
- USB printer
- Serial printer
- IrDA printer

The other types are needed, if you want to configure a printer inside your network.

Figure C.3: Specify Your Printer Type
In the next step, select the interface your printer is connected to. The dialog can look slightly different, depending on what you have selected before.

Figure C.4: Specify the Interface Your Printer is Connected To

Select an interface and click on the Next button.
C Detailed Configuration of the Print Management CUPS

Then enter a name for your print queue in the Name for printing text field. If you want, you can enter a description of your printer in the Description of Printer text field and the printer location in the Location of Printer text field.

![Figure C.5: Select a Name for Your Print Queue](image)

Click the Next button to see the Selection dialog for the printer model.
C.2 Change the Printer Configuration

Select the name of the manufacturer of your printer from the left side of the window. Then you can select the model from the right side of the window.

![Printer Configuration Window](image)

Figure C.6: Select the Model of Your Printer

After clicking the **Next** button, you will see the final dialog.
At this point, you can test your printer configuration by clicking the **Test** button. If you want to change any settings, click the **Edit** button. For example, you might want to change the default page size or the default paper tray. If you are satisfied, press the **OK** button.

![Figure C.7: The Overview of Your Printer Configuration](image)
List of Figures

3.1 The Boot Menu ........................................... 15
3.2 Language for the Installation Process ......................... 17
3.3 Select a Graphical User Interface .......................... 18
3.4 The GNOME User Interface ................................ 19
3.5 The KDE User Interface .................................. 20
3.6 Installation Settings ...................................... 21
3.7 Specify the root Password .................................. 23
3.8 Network Configuration ..................................... 24
3.9 Test the Network Configuration .............................. 25
3.10 Select the User Authentication Method ..................... 26
3.11 Configure the First User ................................... 27
3.12 The Release Notes ........................................ 28
3.13 The Hardware Configuration ............................... 29
4.1 The Login Mask ........................................... 34
4.2 The GNOME Work Environment .............................. 35
4.3 The System Menu .......................................... 36
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.4</td>
<td>The Logout Menu</td>
<td>37</td>
</tr>
<tr>
<td>4.5</td>
<td>Shutting Down Linux Before Switching Off</td>
<td>38</td>
</tr>
<tr>
<td>4.6</td>
<td>The Top Panel</td>
<td>39</td>
</tr>
<tr>
<td>4.7</td>
<td>Virtual Desktops in the Bottom Panel</td>
<td>40</td>
</tr>
<tr>
<td>4.8</td>
<td>Submenus Marked with a Small Arrow</td>
<td>41</td>
</tr>
<tr>
<td>4.9</td>
<td>The Personal Settings Menu</td>
<td>43</td>
</tr>
<tr>
<td>4.10</td>
<td>Icons in the Title Bar of a Window</td>
<td>44</td>
</tr>
<tr>
<td>4.11</td>
<td>The Personal Settings Menu</td>
<td>46</td>
</tr>
<tr>
<td>4.12</td>
<td>The GNOME Terminal</td>
<td>50</td>
</tr>
<tr>
<td>4.13</td>
<td>GNOME Command Line</td>
<td>50</td>
</tr>
<tr>
<td>5.1</td>
<td>Structure of the File System</td>
<td>55</td>
</tr>
<tr>
<td>5.2</td>
<td>Nautilus at the First Start-Up</td>
<td>57</td>
</tr>
<tr>
<td>5.3</td>
<td>Nautilus Showing the Parent Directories</td>
<td>58</td>
</tr>
<tr>
<td>5.4</td>
<td>File Permissions</td>
<td>59</td>
</tr>
<tr>
<td>5.5</td>
<td>Create a New Directory</td>
<td>61</td>
</tr>
<tr>
<td>5.6</td>
<td>Copy a File</td>
<td>63</td>
</tr>
<tr>
<td>5.7</td>
<td>Paste a Copied File</td>
<td>63</td>
</tr>
<tr>
<td>5.8</td>
<td>Discard a File in the Trash</td>
<td>65</td>
</tr>
<tr>
<td>5.9</td>
<td>Emptying the Trash</td>
<td>66</td>
</tr>
<tr>
<td>5.10</td>
<td>Linking Functions</td>
<td>67</td>
</tr>
<tr>
<td>5.11</td>
<td>The Search Utility</td>
<td>69</td>
</tr>
<tr>
<td>5.12</td>
<td>Successful Search</td>
<td>70</td>
</tr>
<tr>
<td>5.13</td>
<td>A USB Stick Is Found</td>
<td>72</td>
</tr>
<tr>
<td>5.14</td>
<td>The Tool for Formatting Floppy Disks</td>
<td>74</td>
</tr>
</tbody>
</table>
List of Figures

6.1 The Icon for the Word Processor in OpenOffice.org . . . . . . . 78
6.2 The Word Processor in OpenOffice.org . . . . . . . 79
6.3 Opening a Microsoft Word File . . . . . . . . . 80
6.4 Saving a Document in Microsoft Word Format . . . . . . . 81
6.5 Configuration of OpenOffice.org . . . . . . . . . 83
6.6 The Help Agent Offers Assistance . . . . . . . . . 84
6.7 OpenOffice.org Help . . . . . . . . . . . 85

7.1 The Icon for Starting Evolution . . . . . . . . . . . 88
7.2 The Configuration of Evolution Starts . . . . . . . . . 88
7.3 Enter Your E-mail Address . . . . . . . . . . . . . 89
7.4 Server for Receiving E-mail . . . . . . . . . . . . . 90
7.5 Specify How Often to Check the Mailbox . . . . . . . . . 92
7.6 Configure the Server for Outgoing Mail . . . . . . . . 93
7.7 Name the Configuration . . . . . . . . . . . . . . . 94
7.8 Select Your Timezone . . . . . . . . . . . . . . . 95
7.9 Read Mail with Evolution . . . . . . . . . . . . . . 96
7.10 Compose a New Email . . . . . . . . . . . . . . . 97
7.11 The Address Book for Managing E-mail Addresses . . . . . . . . . . 100
7.12 Create a New Entry in the Address Book . . . . . . . . . 101
7.13 Keep Track of Appointments with Evolution . . . . . . . . . 103
7.14 Create a New Schedule Entry . . . . . . . . . . . . . 104
7.15 The Evolution To-do List . . . . . . . . . . . . . . 105
7.16 Manage the Gaim Accounts . . . . . . . . . . . . . 107
7.17 Add a New AIM/ICQ Account . . . . . . . . . . . . . 108
### List of Figures

<table>
<thead>
<tr>
<th>Number</th>
<th>Figure Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.18</td>
<td>The Login Dialog of Gaim</td>
<td>109</td>
</tr>
<tr>
<td>7.19</td>
<td>The List of Buddies</td>
<td>110</td>
</tr>
<tr>
<td>7.20</td>
<td>Start Chatting with Gaim</td>
<td>111</td>
</tr>
<tr>
<td>7.21</td>
<td>Gaim Waiting for Chat Invitations</td>
<td>111</td>
</tr>
<tr>
<td>8.1</td>
<td>Dialog for Saving a Screenshot</td>
<td>114</td>
</tr>
<tr>
<td>8.2</td>
<td>The OpenOffice.org Draw Main Window</td>
<td>116</td>
</tr>
<tr>
<td>8.3</td>
<td>The Connector Tool</td>
<td>117</td>
</tr>
<tr>
<td>8.4</td>
<td>The Gimp Main Window</td>
<td>119</td>
</tr>
<tr>
<td>8.5</td>
<td>The Effect of Brightness and Contrast</td>
<td>121</td>
</tr>
<tr>
<td>8.6</td>
<td>Color Correction on Eyes</td>
<td>122</td>
</tr>
<tr>
<td>8.7</td>
<td>The Effect of the Artistic → Cubism... Filter</td>
<td>123</td>
</tr>
<tr>
<td>8.8</td>
<td>The Diagram Editor</td>
<td>125</td>
</tr>
<tr>
<td>9.1</td>
<td>The Icon of Firefox</td>
<td>130</td>
</tr>
<tr>
<td>9.2</td>
<td>Navigation Icons of Firefox</td>
<td>131</td>
</tr>
<tr>
<td>9.3</td>
<td>Manage Bookmarks in Firefox</td>
<td>132</td>
</tr>
<tr>
<td>9.4</td>
<td>Tabbed Browsing with Firefox</td>
<td>133</td>
</tr>
<tr>
<td>9.5</td>
<td>Configuration Dialog of Firefox</td>
<td>134</td>
</tr>
<tr>
<td>9.6</td>
<td>The Password Manager</td>
<td>135</td>
</tr>
<tr>
<td>9.7</td>
<td>Theme Manager</td>
<td>136</td>
</tr>
<tr>
<td>10.1</td>
<td>The Job Tab of the GNOME Print Dialog</td>
<td>141</td>
</tr>
<tr>
<td>10.2</td>
<td>The Printer Tab of the GNOME Print Dialog</td>
<td>142</td>
</tr>
<tr>
<td>10.3</td>
<td>The Paper Tab of the GNOME Print Dialog</td>
<td>142</td>
</tr>
<tr>
<td>10.4</td>
<td>All Available Printers</td>
<td>144</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>10.5</td>
<td>A Print Job Is Waiting</td>
<td>144</td>
</tr>
<tr>
<td>11.1</td>
<td>The User Interface of File Roller</td>
<td>148</td>
</tr>
<tr>
<td>11.2</td>
<td>File Roller Displays the Contents of an Archive</td>
<td>150</td>
</tr>
<tr>
<td>11.3</td>
<td>The Network File System</td>
<td>152</td>
</tr>
<tr>
<td>11.4</td>
<td>The Available Devices</td>
<td>153</td>
</tr>
<tr>
<td>11.5</td>
<td>Some Workstations in the Local Network</td>
<td>154</td>
</tr>
<tr>
<td>11.6</td>
<td>Some Workstations in the Network</td>
<td>154</td>
</tr>
<tr>
<td>11.7</td>
<td>Access a Share on Workstations DA2</td>
<td>155</td>
</tr>
<tr>
<td>11.8</td>
<td>Log in Dialog of Novell’s iFolder</td>
<td>156</td>
</tr>
<tr>
<td>11.9</td>
<td>Specify the Local iFolder Location</td>
<td>157</td>
</tr>
<tr>
<td>11.10</td>
<td>Setup Dialog of iFolder</td>
<td>157</td>
</tr>
<tr>
<td>11.11</td>
<td>Enter an iFolder Pass Phrase</td>
<td>158</td>
</tr>
<tr>
<td>11.12</td>
<td>The iFolder Icon on the Desktop</td>
<td>158</td>
</tr>
<tr>
<td>11.13</td>
<td>The Log File of the iFolder Activity</td>
<td>159</td>
</tr>
<tr>
<td>11.14</td>
<td>All Important Information about Your iFolder Account</td>
<td>160</td>
</tr>
<tr>
<td>11.15</td>
<td>Set Synchronization Preferences</td>
<td>161</td>
</tr>
<tr>
<td>11.16</td>
<td>The K3B User Interface</td>
<td>162</td>
</tr>
<tr>
<td>11.17</td>
<td>Create a New Audio CD</td>
<td>163</td>
</tr>
<tr>
<td>11.18</td>
<td>Create a New Data CD</td>
<td>164</td>
</tr>
<tr>
<td>11.19</td>
<td>The Burn Dialog for Creating a New Data CD</td>
<td>165</td>
</tr>
<tr>
<td>11.20</td>
<td>The Burn Dialog for Copying a CD</td>
<td>166</td>
</tr>
<tr>
<td>11.21</td>
<td>Clear a CD-RW</td>
<td>167</td>
</tr>
<tr>
<td>12.1</td>
<td>Become <code>root</code> to Start YaST</td>
<td>171</td>
</tr>
<tr>
<td>12.2</td>
<td>Become <code>root</code> in a Shell</td>
<td>172</td>
</tr>
</tbody>
</table>
**List of Figures**

12.3 Use the Taskbar to Kill a Process .................................................. 173
12.4 All Currently Running Processes for the Current User .......................... 174
12.5 The YaST Main Menu ........................................................................... 177
12.6 Installing and Uninstalling Software with YaST ................................. 178
12.7 The Most Important YaST Software Installation Symbols ..................... 179
12.8 Red Carpet RPM File Installation ......................................................... 180
12.9 Update your System with Red Carpet ............................................... 181
12.10 Activate Red Carpet ............................................................................ 182
13.1 The Help for Novell Linux Desktop .................................................... 184
14.1 Play an Audio CD ................................................................................. 188
14.2 The RealPlayer Configuration Wizard ................................................. 189
14.3 RealPlayer Configured .......................................................................... 189
14.4 Play an MP3 File in RealPlayer ............................................................ 190
14.5 Pump up the Volume ............................................................................. 190
14.6 Be the DJ of your Computer ................................................................. 191
14.7 Watch a Movie with Real Player .......................................................... 192
14.8 Watch an MPEG Movie with Totem Movie Player ............................... 193
14.9 Iagno is an Othello game ..................................................................... 194
14.10 The Gnome Version of Minesweeper .................................................. 195
14.11 The Worm Collects Diamonds ............................................................... 196
14.12 Remove Balls with the Same Color ..................................................... 197
14.13 The Gnome Version of Solitaire ......................................................... 198

B.1 Network Configuration ............................................................................ 206
## List of Figures

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>B.2</td>
<td>The Configured Network Cards</td>
<td>207</td>
</tr>
<tr>
<td>B.3</td>
<td>The Activated Network Cards</td>
<td>208</td>
</tr>
<tr>
<td>B.4</td>
<td>Network Address Setup</td>
<td>209</td>
</tr>
<tr>
<td>B.5</td>
<td>Change Setting from DHCP</td>
<td>210</td>
</tr>
<tr>
<td>B.6</td>
<td>Configure Host Name and Name Server</td>
<td>210</td>
</tr>
<tr>
<td>B.7</td>
<td>Specify the Default Gateway</td>
<td>211</td>
</tr>
<tr>
<td>C.1</td>
<td>The Hardware Configuration</td>
<td>214</td>
</tr>
<tr>
<td>C.2</td>
<td>The Printer Configuration</td>
<td>215</td>
</tr>
<tr>
<td>C.3</td>
<td>Specify Your Printer Type</td>
<td>216</td>
</tr>
<tr>
<td>C.4</td>
<td>Specify the Interface Your Printer is Connected To</td>
<td>217</td>
</tr>
<tr>
<td>C.5</td>
<td>Select a Name for Your Print Queue</td>
<td>218</td>
</tr>
<tr>
<td>C.6</td>
<td>Select the Model of Your Printer</td>
<td>219</td>
</tr>
<tr>
<td>C.7</td>
<td>The Overview of Your Printer Configuration</td>
<td>220</td>
</tr>
</tbody>
</table>
List of Tables

4.1 Personal Settings: Personal Category . . . . . . . . 47
4.2 Personal Settings: Appearance Category . . . . . . . . 47
4.3 Personal Settings: Hardware Category . . . . . . . . 48
4.4 Personal Settings: System Category . . . . . . . . 48

5.1 Search Strings and Results . . . . . . . . . . . . . . 70

6.1 OpenOffice.org Components . . . . . . . . . . . . . . 78

12.1 System Monitor Information . . . . . . . . . . . . . . 175

A.1 Office Applications . . . . . . . . . . . . . . . . . . . . 201
A.2 Internet Applications . . . . . . . . . . . . . . . . . . . . 202
A.3 Data and File Management Applications . . . . . . . . 202
A.4 Multimedia Applications . . . . . . . . . . . . . . . . . . 203
A.5 Publishing Applications . . . . . . . . . . . . . . . . . . 203

©2004 Novell Inc., the leading provider of Information Solutions
List of Tables

©2004 Novell Inc., the leading provider of Information Solutions
Index

symbols
\ .......................... 10
~ .......................... 56
/ .......................... 10, 54
/dataX/ ..................... 56
/home/ ..................... 56
/media/ .................... 56
/mnt/ ....................... 56
/root/ ...................... 56
/tmp/ ....................... 56

A
access permission ...... see file permission
Acrobat Reader ............ 82
addressbook  see Evolution, addressbook
administrator  see root
archive files ................ 151
archiving files .......... 148
attachment ................. 98
audio CD .................. 188
authentication .......... 26
AVI  ....................... 193

B
backslash ................. 10

C
CD  ....................... 71
audio  .................... 188
burn  ..................... 162–167
copy  ..................... 166
create new ............. 163–165
image .................. 167
CD-RW ................... 167
CDDDB ................... 188
chart ..................... 125–127
Chat  see Gaim
clipboard ................ 42
collaboration ........... 87–112
command line ........... 49
communication .......... 87–112
Components ............. 14
configuration .......... 23–31
network ................ 205–212
printer .................. 213–220
CrossOver Office ....... 191

D
data backup  see File Roller
desktop .................. 38–49
icons  see icons, desktop
temporary ................ 40
DHCP ................... 25, 206, 207
diagram ................ 125–127
directory ................ 54
create .................. 61–62
rename ................... 64
distribution .......... 8, 9
Distribution ........... 8–9
DNS  ...................... 209
domain name .......... 210
download ................. 4
drag and drop .......... 62, 67
drive characters ........ 10
DVD .................... 71, 191
copy ..................... 167
image .................. 167
DVD+RW ................. 167
DVD-RW ................ 167

E
e-mail  see Evolution
Evolution ............... 39, 88–106
account ................ 94
addressbook .......... 100–102
attachment ............ 98
Calendar .............. 102–104
configuration ......... 88–95

©2004 Novell Inc., the leading provider of Information Solutions 231
Index

identity .................. 89
mail client ............... 96–100
new mail .................. 97
read mail .................. 96
reply mail .................. 98
server ....................... 90–94
tasks ......................... 105
timezone ..................... 95
write mail .................. 97
EvolutionAppointments . see Evolution, Calendar
executable file .............. 10
EXE file ..................... 10
file ....................... 54
compress .................. 149
copy ....................... 62–63
delete ....................... 64–66
link ......................... 66–68
move ....................... 62–63
rename ...................... 64
search ...................... 68–71
select ....................... 63
fi le name .................. 54
special characters ........ 54
fi le owner ............... 58–61
fi le permission .......... 58–61
change ................... 60
directories ............... 60
fi les ....................... 60
group .................... 59
others .................... 59
owner .................... 59
File Roller ............... 148, 151
fi le system ............... 53–74
structure .................. 54–56
Firefox .................. 39, 129–138
bookmarks ............. 132–133
configuration ........ 134
icon bar .................. 130
passwords ............... 135
themes .................. 135
floppy disk ............ 71, 73–74
folder ........ see directory
format ........ see floppy disk
G
Gaim .................. 106–111
configuration .......... 106
games .................. 194–198
Gateway .................. 211
Gimp .................. 118–128
brightness ............. 120
color correction ........ 120
contrast ............. 120
effects .................. 123
magic wand tool ....... 122
magnifying glass tool .... 121
masking ........ 121–123
Undo ............. 120
 GNOME ........ 33–52
bottom panel .......... 40
Help menu ........ 39
menu ........ 43
panel ........ 38
Panel Notification Area .... 39
personal settings see personal settings
Programs menu .... 39, 41
System menu .... 35, 39, 43
top panel ........ 38–40
Window List .......... 40
graphics card ........ 28
H
hardware configuration ..... 28
help .................. 183–186
Help Center ........ 184
History ........ 8
host name .................. 209
I
Iagno .................. 194
icons .................. 42–43
desktop ........ 39, 42
panel ........ 42
Programs menu ........ 43
iFolder .................. 155–161
IMAP .................. 90
installation ........ 13–31
instant messaging see Gaim
IP address ........ 209
K
K3B .................. 162–167
kernel .................. 9, 172
KsCD .................. 188
language .................. 17
link see fi le, link
Linus Torvalds ........ 8
logging in .................. 34–35
logging out ........ 35–37
login mask ........ 34, 37
M
mail see Evolution
mbox .................. 91
menu see KDE menu
MH .................. 91
Microsoft Office .... 79–82
Mines .................. 195
Minesweeper ........ 195
mixer .................. 191
mouse buttons ........ 42
movie .................. 191–193
Mozilla see Firefox
MP3 .................. 188
MPEG .................. 193
multitasking ........ 172
music 188–190

N
Nautilus 57–68
Netscape 130
Network 24, 205–212
shares 155
NFS (Network File System) 151–152
Nibbles 196
Novell Linux Desktop Help Center 184

O
Ogg Vorbis 188
OpenOffice.org 39, 77–86
compatibility 79–82
components 79
configuration 82
Draw 116–118
Help Agent 83
history 78
Online Help 83
PDF export 82
operating system 9
Othello 194
owner see file owner

P
package 176
panel 42
passwd 51–52
password 34
change see passwd
root 23
user 26
PDF 82
permission see file permission
personal settings 46–49
pixel images 118
POP 90
print 146
daemon 140
delete job 145
dialog 141–143
jobs 143–146
queue 140, 143
printer 28
configuration 213–220
printing 139
process 172
state 173
Quicktime 191

R
Real Player 192
reboot 37–38
reovable media 71–74
root 11, 56, 170–172
password 23
root directory 54
RPM 176

S
Samba 152
Same 197
Screenshot 82, 114–115
search see file, search
shares 152–155
shut down 37–38
slash 10
SMTP 93
software
installation 176–181
Solitaire 198
soundcard 28
special permissions 61
StarOffice ce 78
system monitor 174

system tray 39

T
tabbed browsing 133
task bar 40
task management 105
Terminal 49
text
 copying 42
 highlight 42
tilde 56
Totem Movie Player 193
training 185
trash can 64–66

U
update 181–182
updates 25
USB device 72
user 26
user interface 10

V
vector drawing 116
video 191–193
virtual desktops 40
volume 190–191

W
WAV 188
web browser see Firefox
wildcard 69
window
behavior 43–45
changing size 44
moving 44
using 43
Windows
Differences 9–11
shares see shares

©2004 Novell Inc., the leading provider of Information Solutions 233
## Index

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>X</strong></td>
<td><strong>Y</strong></td>
<td><strong>Z</strong></td>
</tr>
<tr>
<td>XMMS</td>
<td>YaST</td>
<td>ZIP file</td>
</tr>
<tr>
<td>188</td>
<td>14–31, 205–220</td>
<td>149</td>
</tr>
</tbody>
</table>

©2004 Novell Inc., the leading provider of Information Solutions